Выполнение внешней обработки в фоновом задании

Публикация № 1058914

Разработка - Практика программирования

ВнешняяОбработка ДлительныеОперации ДлительнаяОперация ФоновыеЗадания Программирование БСП Фон Обработка СведенияОВнешнейОбработке ВыполнитьКоманду Форма ДополнительныеОтчетыИОбработки

149
Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

Warning

Данная статья не претендует на оригинальность и не является конечным решением.

Подходы решения задач и примеры программного кода несут исключительно обучающий характер.

 

Существуют ситуации, когда нужно реализовать некий алгоритм и выполнить его в фоновом режиме. Подобных ситуаций может быть масса, а возможностей реализаций в 1С мало и все они сложные.

Ниже представлен вариант реализации длительной операции из внешней обработки. Обязательные требования: обработка должна быть добавлена в справочник ДополнительныеОтчетыИОбработки и наличие БСП v3.

Итак, поехали!

  1. Управляемая форма:
  2.  
     Демонстрационный код модуля внешней обработки (тут все топорно просто):
    
    Функция СведенияОВнешнейОбработке() Экспорт
    	
    	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
    	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
    	ПараметрыРегистрации.БезопасныйРежим = Ложь;
    	
    	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    	НоваяКоманда.Представление = Метаданные().Синоним;
    	НоваяКоманда.Идентификатор = "Открыть форму";
    	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
    	
    	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    	НоваяКоманда.Представление = "Выполнить мой алгоритм";
    	НоваяКоманда.Идентификатор = НоваяКоманда.Представление;
    	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    	
    	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    	НоваяКоманда.Представление = "Выполнить тест";
    	НоваяКоманда.Идентификатор = НоваяКоманда.Представление;
    	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    	
    	Возврат ПараметрыРегистрации;
    	
    КонецФункции
    
    Процедура МояДлительнаяПроцедура()
    	
    	ВремяФиниша = ТекущаяДата() + 100;
    	Пока ТекущаяДата() < ВремяФиниша Цикл
    		Процент = 100 - (ВремяФиниша - ТекущаяДата());
    		Если НЕ (Процент % 10) И Процент Тогда
    			ДлительныеОперации.СообщитьПрогресс(Процент, СтрШаблон("Задание пройдено на %1 процентов", Процент));
    		КонецЕсли;
    	КонецЦикла;
    	
    КонецПроцедуры
    
    Функция ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыКоманды) Экспорт
    	
    	// поиск и выполнение запрошенной команды
    	Если ИдентификаторКоманды = "Выполнить мой алгоритм" Тогда
    		МояДлительнаяПроцедура();
    	ИначеЕсли ИдентификаторКоманды = "Выполнить тест" Тогда
    		Сообщить("Тест пройден");
    	КонецЕсли;
    	
    КонецФункции
    

     

  3. Сама реализация запуска кода модуля внешней обработки в фоновом задании из управляемой формы:

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    	
    	// получим объект обработки
    	ВнешняяОбработка = РеквизитФормыВЗначение("Объект");
    	
    	// если обработка открыта из справочника проверим заполненность ссылки
    	Параметры.Свойство("ДополнительнаяОбработкаСсылка", ДополнительнаяОбработкаСсылка);
    	
    	// если пустая значит открыти из вне, нужно поискать ее в справочнике
    	Если ДополнительнаяОбработкаСсылка.Пустая() Тогда
    		ДополнительнаяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ВнешняяОбработка.Метаданные().Синоним);
    	КонецЕсли;
    	
    	// если забыли добавить в справочник выполнить в фоне не получится :-(
    	ДоступноВыполнениеВФоне = НЕ ДополнительнаяОбработкаСсылка.Пустая();
    	
    	// получим сведения о внешней обработке
    	СведенияОВнешнейОбработке = ВнешняяОбработка.СведенияОВнешнейОбработке();
    	
    	// загрузим все идентификаторы и представления команд в таблицу формы
    	Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    	ТаблицаКоманд.Загрузить(СведенияОВнешнейОбработке.Команды.Скопировать(Новый Структура("Использование", Использование)));
    	// заполним список выбора команд внешней обработки
    	Элементы.КомандаОбработки.СписокВыбора.ЗагрузитьЗначения(ТаблицаКоманд.Выгрузить().ВыгрузитьКолонку("Представление"));
    	
    КонецПроцедуры
    
    &НаСервере
    Процедура ВыполнитьМетодТекущегоОбъекта(ИдентификаторКоманды)
    	
    	ВнешняяОбработка = РеквизитФормыВЗначение("Объект");
    	ВнешняяОбработка.ВыполнитьКоманду(ИдентификаторКоманды, Новый Структура);
    	
    КонецПроцедуры
    
    // это взято из Справочник ДополнительныеОтчетыИОбработки ФормаЭлемента 
    &НаСервереБезКонтекста
    Функция НачатьВыполнениеСервернойКомандыВФоне(ВыполняемаяКоманда, УникальныйИдентификатор)
    	ИмяПроцедуры = "ДополнительныеОтчетыИОбработки.ВыполнитьКоманду";
    	
    	ПараметрыПроцедуры = Новый Структура("ДополнительнаяОбработкаСсылка, ИдентификаторКоманды, ОбъектыНазначения");
    	ПараметрыПроцедуры.ДополнительнаяОбработкаСсылка = ВыполняемаяКоманда.Ссылка;
    	ПараметрыПроцедуры.ИдентификаторКоманды          = ВыполняемаяКоманда.Идентификатор;
    	ПараметрыПроцедуры.ОбъектыНазначения             = ВыполняемаяКоманда.ОбъектыНазначения;
    	
    	НастройкиЗапуска = ДлительныеОперации.ПараметрыВыполненияВФоне(УникальныйИдентификатор);
    	НастройкиЗапуска.НаименованиеФоновогоЗадания = НСтр("ru = 'Дополнительные отчеты и обработки: Выполнение серверного метода обработки'");
    	
    	Возврат ДлительныеОперации.ВыполнитьВФоне(ИмяПроцедуры, ПараметрыПроцедуры, НастройкиЗапуска);
    	
    КонецФункции
    
    &НаКлиенте
    Процедура ВыполнитьКомандуВФоне(ИдентификаторКоманды)
    	
    	// настройки ожидания
    	НастройкиОжидания = ДлительныеОперацииКлиент.ПараметрыОжидания(ЭтаФорма);
    	НастройкиОжидания.ВыводитьПрогрессВыполнения = Истина;
    	НастройкиОжидания.ВыводитьСообщения = Истина;
    	НастройкиОжидания.ТекстСообщения = НСтр("ru = 'Выполняется обработка данных.'");
    	
    	// выполнить команду
    	ВыполняемаяКоманда = Новый Структура("Ссылка, Идентификатор, ОбъектыНазначения", ДополнительнаяОбработкаСсылка, ИдентификаторКоманды, Новый Массив);
    	ДлительнаяОперация = НачатьВыполнениеСервернойКомандыВФоне(ВыполняемаяКоманда, ЭтаФорма.УникальныйИдентификатор);
    	ДлительныеОперацииКлиент.ОжидатьЗавершение(ДлительнаяОперация, Неопределено, НастройкиОжидания);
    	
    КонецПроцедуры
    
    &НаСервере
    Функция ПолучитьИдентификаторВыбраннойКоманды()
    	// получим выбранный идентификатор
    	Возврат ТаблицаКоманд.Выгрузить().Найти(КомандаОбработки).Идентификатор;
    КонецФункции
    
    &НаКлиенте
    Процедура ВыполнитьКоманду(Команда)
    	
    	Если ПустаяСтрока(КомандаОбработки) Тогда
    		Возврат;
    	КонецЕсли;
    	
    	// получим выбранный идентификатор
    	ИдентификаторКоманды = ПолучитьИдентификаторВыбраннойКоманды();
    	
    	// начать обработку данных
    	Если ДоступноВыполнениеВФоне Тогда
    		ВыполнитьКомандуВФоне(ИдентификаторКоманды);
    	Иначе
    		ВыполнитьМетодТекущегоОбъекта(ИдентификаторКоманды);
    	КонецЕсли;
    	
    	КомандаОбработки = "";
    	
    КонецПроцедуры

     

  4. Результат:

Описание работы алгоритма:

  • Получает все команды из функции "СведенияОВнешнейОбработке()";
  • Отбирает только те, где "Использование = ТипКомандыВызовСерверногоМетода";
  • Выводит их пользователю для запуска;
  • После нажатия на команду, получает ее идентификатор;
  • Выполняет запуск команды через ДлительныеОперации.ВыполнитьВФоне();
    • Передает ссылку на ДополнительныеОтчетыИОбработки и идентификатор команды;
    • Фоновое задание получает экземпляр обработки из справочника, подключает и запускает стандартную процедуру "ВыполнитьКоманду()";
    • Выполняет передачу прогресса и сообщений;
  • Выводит меню ожидания с прогрессом выполнения и сообщениями.

Плюсы использования данного подхода:

  • Отсутствие какого либо другого варианта;
  • По сути делает аналогичные действия, как если в справочнике дополнительных отчетов и обработок - нажать на кнопку "Выполнить";
  • Выводит прогресс и сообщения;
  • Вместо пустого массива в "ОбъектыНазначения" можно передать полезные данные в фоновое задание.

 

149

Специальные предложения

Лучшие комментарии
16. Xershi 761 20.05.19 21:05 Сейчас в теме
(13) ключевой плюс этой публикации в том, что все разжевано без лишних соплей и отсебятины. Описание хромает, но зато четко дает понять, что пилить конфу не надо, рисовать форму не надо, а есть не только прогресс в процентах, но и доп текст, куда можно остаток времени записать или другую информацию! Все есть в БСП, главное это правильно написать код, а это мы и так умеем!
Остальные комментарии
Избранное Подписка Сортировка: Древо
1. qwinter 610 12.05.19 11:38 Сейчас в теме
Ну и любят же 1Сники велосипеды)))
creatermc; Eret1k; +2 Ответить
2. qwinter 610 12.05.19 11:45 Сейчас в теме
Отсутствие какого либо другого варианта;

Не благодарите)

3. Eret1k 689 12.05.19 11:50 Сейчас в теме
(2) Я имел в виду варианты запуска кода модуля в ФЗ, а за то что из обработки можно сделать регламентное задание благодарим БСП.
12. rpgshnik 1773 13.05.19 05:14 Сейчас в теме
4. Xershi 761 12.05.19 13:42 Сейчас в теме
Ранее процент выполнения длительной операции можно было вывести только если на форме нарисовать элементы. С версии БСП 3.0 это уже не нужно или и ранее так работало?
5. Xershi 761 12.05.19 13:57 Сейчас в теме
А понял в чем дело. Использовал другой код.
&НаКлиенте
Процедура ВыполнитьЗагрузкуКурсовФоново()
	
	Если ЗначениеЗаполнено(Объект.ИдентификаторКоманды) Тогда
		
		//ПараметрыКоманды = ДополнительныеОтчетыИОбработкиКлиент.ПараметрыВыполненияКомандыВФоне(Параметры.ДополнительнаяОбработкаСсылка);
		ПараметрыКоманды = Новый Структура();
		ПараметрыКоманды.Вставить("ДополнительнаяОбработкаСсылка",	Объект.ОбъектСсылка);
		ПараметрыКоманды.Вставить("СопровождающийТекст",			НСтр("ru = 'Выполняется загрузка курсов валют...'"));
		ПараметрыКоманды.Вставить("ФормаВладелец",					ЭтаФорма);
		ПараметрыКоманды.Вставить("СписокВалют",					ПолучитьАдресТаблицыВалют());
		ПараметрыКоманды.Вставить("НачалоПериода",					Объект.НачалоПериода);
		ПараметрыКоманды.Вставить("ОкончаниеПериода",				Объект.ОкончаниеПериода);
		
		ОписаниеОповещения = Новый ОписаниеОповещения("ЗавершениеЗагрузкиКурсовФоново", ЭтотОбъект);
		
		ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьКомандуВФоне(Объект.ИдентификаторКоманды, ПараметрыКоманды, ОписаниеОповещения);
		
	Иначе
		
		ВыполнитьЗагрузкуКурсовНаСервере();
		
	КонецЕсли;

КонецПроцедуры
Показать
6. Xershi 761 12.05.19 14:14 Сейчас в теме
Переписал на ваш метод:
&НаКлиенте
Процедура ВыполнитьЗагрузкуКурсовФоново()
	
	Если ЗначениеЗаполнено(Объект.ИдентификаторКоманды) Тогда
		
		////ПараметрыКоманды = ДополнительныеОтчетыИОбработкиКлиент.ПараметрыВыполненияКомандыВФоне(Параметры.ДополнительнаяОбработкаСсылка);
		ПараметрыКоманды = Новый Структура();
		ПараметрыКоманды.Вставить("ДополнительнаяОбработкаСсылка",	Объект.ОбъектСсылка);
		ПараметрыКоманды.Вставить("СопровождающийТекст",			НСтр("ru = 'Выполняется загрузка курсов валют...'"));
		//ПараметрыКоманды.Вставить("ФормаВладелец",					ЭтаФорма);
		ПараметрыКоманды.Вставить("СписокВалют",					ПолучитьАдресТаблицыВалют());
		ПараметрыКоманды.Вставить("НачалоПериода",					Объект.НачалоПериода);
		ПараметрыКоманды.Вставить("ОкончаниеПериода",				Объект.ОкончаниеПериода);
		//
		ПараметрыКоманды.Вставить("ИдентификаторКоманды",			Объект.ИдентификаторКоманды);
		ПараметрыКоманды.Вставить("ОбъектыНазначения",				Новый Массив);
		ОписаниеОповещения = Новый ОписаниеОповещения("ЗавершениеЗагрузкиКурсовФоново", ЭтотОбъект);
		//
		//ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьКомандуВФоне(Объект.ИдентификаторКоманды, ПараметрыКоманды, ОписаниеОповещения);
				
		// настройки ожидания
		НастройкиОжидания = ДлительныеОперацииКлиент.ПараметрыОжидания(ЭтаФорма);
		НастройкиОжидания.ВыводитьПрогрессВыполнения = Истина;
		НастройкиОжидания.ВыводитьСообщения			 = Истина;
		НастройкиОжидания.ТекстСообщения			 = НСтр("ru = 'Выполняется загрузка курсов валют...'");
		
		// выполнить команду
		//ВыполняемаяКоманда = Новый Структура("Ссылка, Идентификатор, ОбъектыНазначения", ДополнительнаяОбработкаСсылка, ИдентификаторКоманды, Новый Массив);
		//ДлительнаяОперация = НачатьВыполнениеСервернойКомандыВФоне(ВыполняемаяКоманда, ЭтаФорма.УникальныйИдентификатор);
		ДлительнаяОперация = НачатьВыполнениеСервернойКомандыВФоне(ПараметрыКоманды, ЭтаФорма.УникальныйИдентификатор);
		ДлительныеОперацииКлиент.ОжидатьЗавершение(ДлительнаяОперация, ОписаниеОповещения, НастройкиОжидания);
		
	Иначе
		
		ВыполнитьЗагрузкуКурсовНаСервере();
		
	КонецЕсли;

КонецПроцедуры
Показать

Не взлетело, прогресса нет. БСП в конфе 3.0.1.314.
В процедуре, которая считает все
ДлительныеОперации.СообщитьПрогресс(Процент, СтрШаблон("Загрузка курсов завершена на %1 %", Процент));		

В статье говорится, что команда должна иметь "ВызовСерверногоМетода". А я открываю форму же через "ОткрытиеФормы". Далее по кнопке вызываю длительную операцию. Выходит команда "ОткрытиеФормы", должна дернуть другую команду "ВызовСерверногоМетода"?
Возможно дело еще в:
ПараметрыРегистрации.Вставить("ВерсияБСП", "2.4.2.169");
Попробую поменять, но думаю не в этом дело.
7. Eret1k 689 12.05.19 17:13 Сейчас в теме
(6)
Команда которая должна быть выполнена в фоне, должна иметь тип: ДополнительныеОтчетыИОбработкиКлиентСервер. ТипКомандыВызовСерверногоМетода();

Код обработки можно отлаживать если, установлен параметр запуска "РежимОтладки", но правда каждый раз придется обновлять обработку в справочнике.

8. Xershi 761 12.05.19 20:40 Сейчас в теме
(7) да заработало! Как через файл, если добавить обработку в справочник, так и через внешние.
Единственный минус, мне нужно передавать параметры, когда я открываю форму.
Команда с "ВызовСерверногоМетода" используется для формирования регламентного задания. Подумаю как обойти это и будет вообще песня!

У меня также есть обработка, которая таким макаром запускает несколько потоков, но там везде был клиентский метод и прогресс не выводился. Возможно ли несколько потоков запустить таким вариантом?
Прикрепленные файлы:
10. Eret1k 689 12.05.19 22:10 Сейчас в теме
(8)
возможно ли несколько потоков запустить таким вариантом?

Да делал такое, НачатьВыполнениеСервернойКомандыВФоне() запускал в цикле, разделяя данные по порциям и передавал их в "ОбъектыНазначения". Собирал массив длительных операций и потом на клиенте опять в цикле передавал их в ДлительныеОперацииКлиент.ОжидатьЗавершение();
11. Xershi 761 12.05.19 23:07 Сейчас в теме
(10) не совсем понял.
ДлительнаяОперация = НачатьВыполнениеСервернойКомандыВФоне(ПараметрыКоманды, ЭтаФорма.УникальныйИдентификатор);
		ДлительныеОперацииКлиент.ОжидатьЗавершение(ДлительнаяОперация, ОписаниеОповещения, НастройкиОжидания);
		

Это делаем в цикле? Для чего собирать ДлительнаяОперация в массив?
22. Nuuq 70 10.10.19 10:42 Сейчас в теме
(7)
Команда которая должна быть выполнена в фоне, должна иметь тип: ДополнительныеОтчетыИОбработкиКлиентСервер. ТипКомандыВызовСерверногоМетода();

Код обработки можно отлаживать если, установлен параметр запуска "РежимОтладки", но правда каждый раз придется обновлять обработку в справочнике.

А можно по подробнее, как отладить?
Я в параметр запуска написал "РежимОтладки", в Конфигураторе - Отладка - Подключение - Автоматическое подключение - галочки стоят Клиентские и внешние соединения на сервере и Фоновые задания (т.о. в табличке Сервер и Тонкий клиент 2 строчки). Открыл обработку в конфигураторе, поставил точку. Добавил (обновил) обработку в справочнике Дополнительных внешних обработок, тут же нажал "Выполнить" - но в отладку не попадает.
ЧЯДНТ?
9. Xershi 761 12.05.19 21:56 Сейчас в теме
Проверил на БСП 2.4.2.169 работает!
А вот на 2.3.2.51 пишет, что прогресс может выводить, а вот сообщения нет.
{ОбщийМодуль.ОбщегоНазначенияКлиентСервер.Модуль(2642)}: Если параметр ПараметрыОжидания.ВыводитьПрогрессВыполнения установлен в Истина, то параметр ПараметрыОжидания.ВыводитьСообщения должен быть установлен в Ложь в ДлительныеОперацииКлиент.ОжидатьЗавершение
		ВызватьИсключение ТекстИсключения;

Посмотрел код, там тоже работает! Только нужно закомментить проверку в общем модуле "ДлительныеОперацииКлиент" процедуре "ПроверитьПараметрыОжидатьЗавершение"
//ОбщегоНазначенияКлиентСервер.Проверить(Не (ПараметрыОжидания.ВыводитьПрогрессВыполнения И ПараметрыОжидания.ВыводитьСообщения), 
		//	НСтр("ru = 'Если параметр ПараметрыОжидания.ВыводитьПрогрессВыполнения установлен в Истина, то параметр ПараметрыОжидания.ВыводитьСообщения должен быть установлен в Ложь'"),
		//	"ДлительныеОперацииКлиент.ОжидатьЗавершение");
		

Она вызывает исключение, а после комментирования все работает!
wowik; Eret1k; +2 Ответить
13. Oldsad 13.05.19 08:34 Сейчас в теме
Существуют ситуации, когда нужно реализовать некий алгоритм и выполнить его в фоновом режиме. Подобных ситуаций может быть масса, а возможностей реализаций в 1С мало и все они сложные.

ничего сложного, делаем поиск по ключевым словам "длительные операции" или "фоновые задания" и находим пару десятков тем на данном форуме с примерами / шаблонами и т.п.

и собственно возникает вопрос: чем данная статья отличается от десятка ей подобных?

Плюсы использования данного подхода:

Отсутствие какого либо другого варианта;

сильное заявление, и очевидно, неверное, т.к. вы всего лишь навсего используете бсп в части длительных операций

По сути делает аналогичные действия, как если в справочнике дополнительных отчетов и обработок - нажать на кнопку "Выполнить";

и это плюс? тогда еще в плюсы можно записать "обработка выполняет заданный ей алгоритм"

Вместо пустого массива в "ОбъектыНазначения" можно передать полезные данные в фоновое задание

без это с позволения сказать "плюса" мы получим обработку бесполезную чуть менее чем полностью

не стал придираться к еще одному плюсу (третьему), как ни странно не во всех примерах фоновых заданий выводятся сообщения
Evg-Lylyk; +1 Ответить
16. Xershi 761 20.05.19 21:05 Сейчас в теме
(13) ключевой плюс этой публикации в том, что все разжевано без лишних соплей и отсебятины. Описание хромает, но зато четко дает понять, что пилить конфу не надо, рисовать форму не надо, а есть не только прогресс в процентах, но и доп текст, куда можно остаток времени записать или другую информацию! Все есть в БСП, главное это правильно написать код, а это мы и так умеем!
18. mrx2012 20.05.19 23:24 Сейчас в теме
Все верно, но с готовым примером проще и быстрее.
14. mrx2012 20.05.19 17:06 Сейчас в теме
Ребята, у кого получился рабочий вариант. Пришлите рыбу , пожалуйста.
15. Eret1k 689 20.05.19 18:56 Сейчас в теме
(14) Держите может поможет
Прикрепленные файлы:
ВыполнитьАлгоритмВФоне.epf
wowik; user774630; +2 Ответить
17. mrx2012 20.05.19 23:20 Сейчас в теме
(15)огромное спасибо за статью и за обработку.
У меня уже была обработка, для для асинхронного выполнения , но в ней очень не хватало индикатора выполнения. Надеюсь теперь будет.
20. max_zhilin 30.08.19 17:45 Сейчас в теме
(15) не работает, не показывает прогресс, да и интерфейс блокирует. БСП 3.0.1.351

В Процедура СообщитьПрогресс срабатывает это:
	Если ПолучитьТекущийСеансИнформационнойБазы().ПолучитьФоновоеЗадание() = Неопределено Тогда
		Возврат;
	КонецЕсли;


Upd: разобрался, был включен режим отладки
19. viplelik 4 23.08.19 16:22 Сейчас в теме
А как сделать чтобы работало прямо из файла? (т.е. без добавления в "Дополнительные отчеты и обработки")

P.S. На новых БСП (3.0.2 и выше)
23. fuser 3 30.10.19 09:26 Сейчас в теме
(19) воспользоваться поиском по сайту (внешняя обработка длительные операции БСП)
21. max_zhilin 30.08.19 17:54 Сейчас в теме
Кстати, вот этот фрагмент успевает за секунду назапускаться сотни раз. Надо как-то ограничить одним разом.
		Если НЕ (Процент % 10) И Процент Тогда
			ДлительныеОперации.СообщитьПрогресс(Процент, СтрШаблон("Задание пройдено на %1 процентов", Процент));
Оставьте свое сообщение

См. также

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Агрегатные функции СКД, о которых мало кто знает 356

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    16316    ids79    44       

Обмен данными. Консистентность vs Многопоточность 27

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Интеграция

Рассмотрим теоретические основы обмена данными. Какие бывают обмены, какие гарантии при этом даются, зачем идти на компромиссы и что при этом может пойти не так. Есть ли идеальная схема?

03.09.2019    5191    m-rv    1       

Перенос данных БП 2.0 => УТ 11 / КА 2 / ERP 2 (перенос остатков, документов и справочников из "1С:Бухгалтерия предприятия 8", ред. 2.0 в "1С:Управление торговлей 8", ред.11 / КА 2 / ERP 2). Обновлено до УТ 11.4.10.х, КА 2.4.10.х, ERP 2.4.10.х! Промо

Перенос позволяет загрузить в УТ 11 / КА 2 / ERP 2 документы за выбранный период, справочную информацию и остатки по счетам бух. учета. Переносятся остатки денежных средств, взаиморасчетов, остатки товаров и материалов на складах. Переносятся девятнадцать основных видов документов за выбранный период и вся нормативно-справочная информация. Есть фильтр по организации. Если нужно переносить что-то дополнительно, то обычно бесплатно дорабатываю правила (перед покупкой согласуйте необходимые доработки).

29700 руб.

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 264

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    19183    ids79    31       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Создание отчетов с помощью СКД - основные понятия и элементы 218

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    24375    ids79    17       

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 222

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    19749    YPermitin    49       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    7921    m-rv    2       

Как настроить правильную техподдержку (helpdesk, service desk на коленке) 39

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8 УУ Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Бесплатно (free) Управление услугами и сервисом

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    9264    siddy    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Преобразование EXCEL в таблицу значений без COM и других извращений 216

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Получение таблицы значений из excel в 1С v8, без COM, внешних источников данных и т.д. EXCELВТаблицуЗначений() - За 10 строчек кода! Реализация протестирована на 1С 8.3.12.1714 (x64).

18.04.2019    14941    9    Eret1k    43       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    10464    m-rv    16       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Копирование числовых ячеек из 1С в Excel 26

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    13141    itriot11    21       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 509

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    39504    GeterX    94       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 129

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    23938    ids79    40       

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git 282

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    39888    stas_ganiev    72       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Вспомогательные инструкции в коде 1С 107

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    22246    tormozit    100       

Из Excel в 1С запросом 33

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    15411    m-rv    5       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Повышаем эффективность разработки правил обмена 125

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    21666    olegtymko    47       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    23341    m-rv    21       

Строим графы средствами 1С (без GraphViz) 44

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    19106    slozhenikin_com    20       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    13318    Rustig    9       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники 96

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    17715    V.Stavinsky    11