Настройка ТСД chiperLab 8001 для УТ 11

Публикация № 308824

Учет и отчетность - Учет ТМЦ

Настройка ТСД chiperLab 8001 Настройка ТСД для ут 11 Терминал сбора данных chiperLab 8001 прошивка для ТСД прошивка для chiperLab 8001

Расширяем функционал ТСД chiperLab 8001 и загружаем сразу 10 документов
Сканируйте 10 накладных за один раз!!!

 

 В данном примере мы рассмотрим, как доработать задачу  в ТСД chiperLab 8001, расширив ее функционал, и подключить к УТ11:

В  файле Revolution8001.AGX содержится доработанная задача, имеющая следующие особенности:

1. Возможность загрузки до 10 различных документов

 


2.В каждой накладной выводится номер накладной, штрих код сканированного товара, ввод сканированного товара, название, счетчик позиций по накладной.

3.Поиск происходит по базе товаров, которые выгружаются в ТСД.

               Установка из коробки

1. Первое, что нужно сделать, это подключить ТСД и установить софт (нам необходим Генератор приложений) аем

2. Настраиваем в генераторе приложений подключение

 

в данном случае через подставку

3. Проверяем настройки в ТСД, соответсвуют ли они настройкам в генераторе приложений

4. Загружаем задачу в ТСД.

Если прошло все успешно, то переходим к следующей части,если нет... учите мат. часть

 Настройка в 1С

1. Заходим в настройки оборудования

 

 

 

 

 

 

2. Добавляем новое устройство на свое рабочее место 

 

 

3. Устанавливаем драйвер(в 11 версии это можно сделать прямо из 1с), настраиваем параметры подключения. Обязательно!!! ставим галочку "не выбирать источник загрузки". Дальше напишу зачем.

 

 

 

 

 

4. Обратите внимание на вкладку "форматы", она должна быть заполнена именно так

 

 

 

 

 

 

5.Ну и теперь самое интересное. Для тех, кто хочет задействовать все 10 накладных, далее... Без этого все будет работать, но документ загрузки будет только 1 и выбираться как задано на вкладке 5 

        Доработка кода

Для того чтобы получить выбор накладной как на рисунке

 

 

 

 

необходимо дописать следующее

общиймодуль.ПодключаемоеОборудованиеСканкодТерминалыСбораДанныхКлиент

Функция НачатьЗагрузку(ОбъектДрайвера, Параметры, ПараметрыПодключения, Количество, ВыходныеПараметры)

Результат = Истина;
ПараметрыПодключения.Вставить("ПоследнийИсточникЗагрузки", "Документ");

Если Параметры.ВыбиратьИсточникЗагрузки Тогда
СписокИсточниковЗагрузки = Новый СписокЗначений();
//начало Яшин А.И. нам не нужна загрузка база данных нам нужно 10 документов
//СписокИсточниковЗагрузки.Добавить("Документ", НСтр("ru='Документ терминала сбора данных'"));
//СписокИсточниковЗагрузки.Добавить("База", НСтр("ru='База терминала сбора данных'"));
СписокИсточниковЗагрузки.Добавить("Документ1", НСтр("ru='Накладная 1'"));
СписокИсточниковЗагрузки.Добавить("Документ2", НСтр("ru='Накладная 2'"));
СписокИсточниковЗагрузки.Добавить("Документ3", НСтр("ru='Накладная 3'"));
СписокИсточниковЗагрузки.Добавить("Документ4", НСтр("ru='Накладная 4'"));
СписокИсточниковЗагрузки.Добавить("Документ5", НСтр("ru='Накладная 5'"));
СписокИсточниковЗагрузки.Добавить("Документ6", НСтр("ru='Накладная 6'"));
СписокИсточниковЗагрузки.Добавить("Документ7", НСтр("ru='Накладная 7'"));
СписокИсточниковЗагрузки.Добавить("Документ8", НСтр("ru='Накладная 8'"));
СписокИсточниковЗагрузки.Добавить("Документ9", НСтр("ru='Накладная 9'"));
СписокИсточниковЗагрузки.Добавить("Документ10", НСтр("ru='Накладная 10'"));

//конец Яшин А.И. нам не нужна загрузка база данных нам нужно 10 документов

ИсточникЗагрузки = СписокИсточниковЗагрузки.ВыбратьЭлемент(НСтр("ru='Выберите источник загрузки данных'"));
Если ИсточникЗагрузки <> Неопределено Тогда
ПараметрыПодключения.ПоследнийИсточникЗагрузки = ИсточникЗагрузки.Значение;
//начало Яшин А.И. нам не нужна загрузка база данных нам нужно 10 документов

//Если ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ" Тогда
// Количество = ОбъектДрайвера.ЗаписейВДокументе(Параметры.НомерДокумента);
//Иначе
// Количество = ОбъектДрайвера.ЗаписейВБазеДанных(Параметры.НомерБазы);
//КонецЕсли;
Если ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ1" Тогда
НомерДокумента=0;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ2" Тогда
НомерДокумента=1; 
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ3" Тогда
НомерДокумента=2;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ4" Тогда
НомерДокумента=3;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ5" Тогда
НомерДокумента=4;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ6" Тогда
НомерДокумента=5;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ7" Тогда
НомерДокумента=6;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ8" Тогда
НомерДокумента=7;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ9" Тогда
НомерДокумента=8;
ИначеЕсли ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ10" Тогда
НомерДокумента=9;
КонецЕсли;
Параметры.Вставить("НомерДокумента" , НомерДокумента);
Количество = ОбъектДрайвера.ЗаписейВДокументе(НомерДокумента); 
//конец Яшин А.И. нам не нужна загрузка база данных нам нужно 10 документов
Иначе
ВыходныеПараметры.Очистить();
ВыходныеПараметры.Добавить(999);
ВыходныеПараметры.Добавить(НСтр("ru='Операция отменена пользователем'"));
Возврат Ложь;
КонецЕсли;
Иначе
Количество = ОбъектДрайвера.ЗаписейВДокументе(Параметры.НомерДокумента);
КонецЕсли;

Если Количество = 0 Тогда
ВыходныеПараметры.Очистить();
ВыходныеПараметры.Добавить(999);
ВыходныеПараметры.Добавить(НСтр("ru='Отсутствуют данные для загрузки из терминала сбора данных.'"));

Результат = Ложь;
ИначеЕсли Количество < 0 Тогда
ВыходныеПараметры.Очистить();
ВыходныеПараметры.Добавить(999);
ВыходныеПараметры.Добавить(ОбъектДрайвера.ОписаниеРезультата);

Результат = Ложь;
КонецЕсли;

Возврат Результат;

КонецФункции

Функция ЗагрузитьСтроку(ОбъектДрайвера, Параметры, ПараметрыПодключения, Штрихкод, Количество, ВыходныеПараметры)

Результат = Истина;
//начало Яшин А.И. 10 документов 
//ФорматИсточника = ?(ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ",
ФорматИсточника = ?(ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ"+(Параметры.НомерДокумента+1),
//конец Яшин А.И.10 документов
Параметры.ФорматДокумента, Параметры.ФорматБазы);
Штрихкод = Неопределено;
Количество = Неопределено;
Разделитель = "";
// начало Яшин А.И. 10 документов
//Если ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ" Тогда
Если ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ"+(Параметры.НомерДокумента+1) Тогда
// конец Яшин А.И.10 документов
Разделитель = Символ(Параметры.РазделительДокумента);
ОбъектДрайвера.ПолучитьЗаписьИзДокумента(Параметры.НомерДокумента);
Иначе
Разделитель = Символ(Параметры.РазделительБазы);
ОбъектДрайвера.ПолучитьЗаписьИзБазыДанных(Параметры.НомерБазы);
КонецЕсли;

Если ОбъектДрайвера.Результат <> 0 Тогда
ВыходныеПараметры.Очистить();
ВыходныеПараметры.Добавить(999);
ВыходныеПараметры.Добавить(ОбъектДрайвера.ОписаниеРезультата);

Результат = Ложь;
Иначе
ДанныеИзТСД = СтрЗаменить(ОбъектДрайвера.Данные, Разделитель, Символы.ПС);

Если ФорматИсточника.Количество() > 0 Тогда
Для Каждого СтрокаФормата Из ФорматИсточника Цикл
Если СтрокаФормата.Наименование = "Штрихкод" Тогда
Попытка
#Если ВебКлиент Тогда
Штрихкод = СтрПолучитьСтроку(ДанныеИзТСД, СтрокаФормата.НомерПоля);
#Иначе
Штрихкод = ОбъектДрайвера["Поле" + СтрокаФормата.НомерПоля];
#КонецЕсли
Исключение
Продолжить;
КонецПопытки;
ИначеЕсли СтрокаФормата.Наименование = "Количество" Тогда
Попытка
#Если ВебКлиент Тогда
Количество = Число(СтрПолучитьСтроку(ДанныеИзТСД, СтрокаФормата.НомерПоля));
#Иначе
Количество = Число(ОбъектДрайвера["Поле" + СтрокаФормата.НомерПоля]);
#КонецЕсли
Исключение
Количество = 0;
КонецПопытки;
КонецЕсли;
КонецЦикла;
Иначе
Штрихкод = ОбъектДрайвера.Поле1;
Попытка
Если ПараметрыПодключения.ПоследнийИсточникЗагрузки = "Документ" Тогда
Попытка
Количество = Число(ОбъектДрайвера.Поле2);
Исключение
Количество = 0;
КонецПопытки;
Иначе
Попытка
Количество = Число(ОбъектДрайвера.Поле8);
Исключение
Количество = 0;
КонецПопытки;
КонецЕсли;
Исключение
ВыходныеПараметры.Очистить();
ВыходныеПараметры.Добавить(999);
ВыходныеПараметры.Добавить(НСтр("ru='Неверный формат данных поля ""Количество"".
|Проверьте настройку задачи терминала.'"));

Результат = Ложь;
КонецПопытки;
КонецЕсли;
КонецЕсли;

Возврат Результат;

КонецФункции

 На выходе получаем ТСД с 10 накладными что очень удобно при отгрузке или приемке нескольких заказов

Скачать файлы

Наименование Файл Версия Размер
Revolution8001.AGX

.AGX 18,51Kb
23.10.14
31
.AGX 18,51Kb 31 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. mar_a 25 09.07.15 09:48 Сейчас в теме
Интересует несколько вещей:
1)терминал я так понял по драйверу только Сканкодовский и с прошивкой/драйвером от Скансити работать в принипе не будет?
2)терминал предположим с родной тайваньской прошивкой соответсвенно через DLL сканкода и скансити не работает, возможна ли настройка связи через другие DLL которые мне еще не встречались (если есть таковые буду рад позаимствовать).
2. Anyxwar 112 09.07.15 15:34 Сейчас в теме
1) можно переделать саму задачу на Скансити,редактор одинаков
2)DLL которые мне еще не встречались........................ все возможно,...........если есть описание к библиотеке.
3. SaLMaN 09.07.18 09:22 Сейчас в теме
(2) Скажите, пжл, какой релиз УТ11 использовался?
настраиваю для УТ10 не получается, если использовать драйвер версии 6.0.3.0 - ругается
" Обращение к процедуре объекта как к функции (УстановитьПараметры)
Ответ = Объект.Драйвер.УстановитьПараметры(Объект.Параметры.Порт "
если использовать драйвер 6.0.8.0 - уже другая ошибка
" Поле объекта не обнаружено (ПараметрыПодключения)
Объект.Драйвер.ПараметрыПодключения.Вставить("ПоследнийИсточникЗагрузки", "Документ"); "
4. Anyxwar 112 09.07.18 13:35 Сейчас в теме
Оставьте свое сообщение

См. также

GGraphics - внешняя компонента для работы с картинками jpg (jpeg), png, bmp, gif, tif Промо

Разработка внешних компонент v8 1cv8.cf Платные (руб)

Позволяет автоматизировать работу с картинками. С помощью компоненты можно измерять размер изображений, поворачивать их, наносить водяные знаки, конвертировать из одного формата в другой. Будет очень полезна для интернет-магазинов и всех, кому постоянно требуется работать с различными графическими форматами. Выполнена по технологии NativeAPI. Работает с форматами: jpg (jpeg), png, bmp, gif, tif

2000 руб.

02.09.2010    54279    62    207    

Интеграция "Библиотеки интеграции МДЛП 1.1.2.7" с типовой конфигурацией

Интеграция Конфигурирование 1С v8 Здравоохранение, медицина, стоматология Россия Бесплатно (free)

Инструкция для интеграции “Библиотеки интеграции МДЛП 1.1.2.7” в типовые конфигурации, на примере конфигурации “Управление нашей фирмой, редакция 1.6 (1.6.18.168)”.

02.03.2020    4220    0    RPGrigorev    3    

Универсальные инструменты 1С

Универсальные обработки Прочие инструменты разработчика v8 1cv8.cf Бесплатно (free)

Свободно распространяемый набор универсальных обработок и отчетов в виде расширения для разработки и поддержки, которое работает во ВСЕХ видах клиентских приложений и во всех операционных системах, которые поддерживает платформа 1С:Предприятие, кроме мобильных. Консоль запросов - консоль отчетов - консоль кода - редактор объектов базы данных - удаление помеченных объектов - поиск и удаление дублей - редактор констант - консоль заданий - групповая обработка справочников и документов - динамический список - поиск ссылок на объект - регистрация изменений для обмена данными - структура хранения базы - консоль HTTP запросов-консоль вебсервисов- консоль сравнения данных- информация о лицензиях- загрузка из табличного документа-файловый менеджер-все функции- навигатор по конфигурации-конструктор регулярных выражений-Выгрузка загрузка XML с фильтрами

21.01.2020    21182    295    cprit    94    

Хранение файлов - как уменьшить размер базы данных

Чистка базы Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Бесплатно (free)

Хранение файлов в базе 1С можно оптимизировать для уменьшения размера хранимых данных.

09.09.2019    7910    0    2tvad    17    

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 Промо

Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки v8 1cv8.cf Платные (руб)

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

2000 руб.

31.01.2019    45476    326    156    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    26236    76    Evil Beaver    119    

Выполнение внешней обработки в фоновом задании

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    26327    0    Eret1k    23    

Немного о графических файлах. Сжатие. Распознавание текста

Инструментарий разработчика v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Простые и доступные методы борьбы с лишним весом графических файлов и распознавание текста.

1 стартмани

06.05.2019    6676    10    tusv    6    

Регулярные выражения без внешних компонент? Легко! Промо

Практика программирования Обмен через XML v8 Бесплатно (free)

Сложный способ организовать проверку строки с помощью регулярного выражения в 1С. При этом ни одна внешняя компонента не пострадала. Ну и от платформы (Linux, MustDie) - не зависит.

04.03.2016    60177    0    starik-2005    99    

Практика перехода на Linux и Postgres в небольшой компании (10 пользователей)

Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

Почему я решил поставить давнему клиенту Linux + Postgres вместо Windows + MS SQL? Что меня останавливало раньше?

22.04.2019    27761    0    starik-2005    169    

HTML-клиент у конфигурации 1С

WEB v8 Бесплатно (free)

Приветствую. В этой публикации опишу свой опыт создания html-клиента для конфигурации 1С с помощью http-сервисов. HTML-клиент в этом случае - это frontend (html + css+ js), который генерирует и выдает пользователю конфигурация + backend, который тоже реализован в этой же конфигурации.

17.04.2019    16851    0    Smaylukk    119    

Уменьшаем трафик: HTTP запрос со сжатием GZIP средствами 1С. На примере выгрузки файлов на Яндекс-диск

WEB v8 1cv8.cf Абонемент ($m)

Обработка демонстрирует отправку тела HTTP запроса со сжатием gzip (метод deflate) средствами платформы 1С. Демонстрация происходит на примере отправки текста или файла на Яндекс.Диск.

1 стартмани

03.09.2018    5831    28    uno-c    0    

Инструменты бухгалтера: Виджеты рабочего стола Промо

Универсальные обработки Рабочее место v8 v8::БУ БП3.0 Абонемент ($m)

Настраиваемые виджеты на начальной странице, своеобразная панель для быстрого доступа к объектам. Виджеты это элементы интерфейса в виде цветных прямоугольников со ссылками на объекты конфигурации. Использование виджетов позволяет сконцентрировать на начальной странице часто используемые функции, например, варианты отчетов, списки документов, или используя виджет вводить новый документ прямо из начальной страницы.

2 стартмани

28.08.2017    35291    170    Bazil    28    

Чтение сжатого gzip, deflate HTTP ответа сервера. Без ВК. Уменьши время загрузки и сократи трафик в 3 раза

WEB v8 1cv8.cf Абонемент ($m)

В платформе 1С:Предприятие не реализовано штатного механизма декодирования ответа веб серверов, в которых присутствует gzip сжатие. Некоторые использовали WinHttpRequest.5.1 , кто-то писал ВК. Друзья, хватит. Вот вам решение.

1 стартмани

08.06.2018    13594    69    Malfarion    16    

Создание подключаемой обработки табличной части с диалогом запроса параметров заполнения (управляемые формы)

Обработка документов Обработка справочников Практика программирования v8::УФ 1cv8.cf Абонемент ($m)

Пошаговый пример покажет, как сделать обработку табличной части для документа, предварительно открывающую диалоговое окно, где пользователь может указать требуемые характеристики (параметры), по которым произойдет обработка.

1 стартмани

03.05.2018    44727    116    Mirage78    15    

Обработка печатной формы WORD клиент-сервер УФ

Универсальные печатные формы v8::УФ 1cv8.cf Абонемент ($m)

Это моя первая статья на данном портале, но попытаюсь изложить все понятно и подробно. Долгое время у меня заняло создание такой вот внешней обработки. Есть очень много примеров, как сделать подобное на неуправляемых формах (2.0) и очень мало информации касательно управляемых(3.0), по крайней мере я многого найти не смог в доступе. Создание подобное обработки выглядит вполне несложно, если производить все действия на сервере, как это было с 2.0, но в нашем случае необходимо инициализировать открытие документа на клиенте, чему сильно мешает отсутствие возможности передать макет Active Document с сервера на клиент.

2 стартмани

14.03.2018    23691    83    LeoKeyn    41    

Gant 1C 2.* - диаграмма Ганта с таблицей + Планировщик + Отчет (8.1, на управляемой форме/Такси 8.2, 8.3) Промо

Рабочее место Универсальные обработки Управление проектом Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет рабочего времени Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет рабочего времени v8 1cv8.cf УУ Абонемент ($m)

Внешняя обработка, аналог MS Project в 1Се для работы с задачами: параллельный ввод данных по задачам и график Ганта, дополнительный режим в виде календаря (планировщик), связывание задач и пересчет длительности и дат с учетом выходных, видов связей и запаздываний, расчет затрат, сохранение/открытие проектов в файл на диск или файл ИБ, импорт/экспорт документов Microsoft Project.

1 стартмани

02.12.2011    135865    1067    rare-avis    210    

“Заставим сканер пищать!” или Получаем обратную связь из 1С при сканировании штрихкодов

Сканер штрих-кода Учет ТМЦ Учет ТМЦ v8 1cv8.cf Абонемент ($m)

Получаем обратную связь из 1С при сканировании штрихкодов.

1 стартмани

10.01.2018    40579    100    vadnevzorov    70    

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена)

Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML v8 КД Бесплатно (free)

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    181721    0    MaxS    285    

Зачем 1С-нику NoSQL и CRDT

WEB Интеграция Бесплатно (free)

В статье речь пойдет о современных инструментах для хранения, транспорта, обработки и обмена данными на примере популярной NoSQL-базы CouchDB.

12.08.2017    22728    0    unpete    27    

Маркировка: 2D Android Штрихкод сканер + драйвер устройства для 1С Промо

Сканер штрих-кода Розничная торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Драйвер торгового оборудования и приложение для Android, телефон или планшет в качестве стандартного штрихкод сканера для платформы 1С.

3 стартмани

29.11.2016    43970    176    dreamadv    110    

Как я стал одинэсником и переехал из провинции в Москву

О жизни Россия Бесплатно (free)

История покорения Москвы.

29.07.2017    16819    0    DmitryKSL    132    

54 ФЗ своими руками

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Бесплатно (free)

Практический опыт внедрения изменений в 54ФЗ в розничной сети, работающей на 1С. Если вы не хотите платить каким-либо подрядчикам, которые "всё сделают и настроят за вас", то статься может оказаться крайне полезной.

17.04.2017    57582    0    comol    124    

Формирование штрихкода EAN-13 в SVG с помощью XDTO

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

В версии платформы 8.3.9 было объявлено о поддержке изображений в формате SVG. Данная обработка демонстрирует работу с данным форматом, а именно его формированием (рисованием). Ну а так как самой популярной картинкой в 1С, наверное, является картинка штрихкода EAN - ее я и решил рисовать.

1 стартмани

24.03.2017    11937    52    kot-stas    19    

Удаление организации из 1С. Чистка базы 1С. Удаление "не удаляемых" объектов Промо

Чистка базы v8 1cv8.cf Абонемент ($m)

Удалить все документы, чтобы в базе осталась только одна организация со своими документами? Удалить всю информацию в регистрах, не связанную с указанной фирмой? Удалить "неудаляемую" номенклатуру? Легко! Используйте эту обработку.

10 стартмани

02.10.2015    51032    309    spy-83    84    

План обмена в формате "EnterpriseData" для 1С 7.7

Обмен через XML 1С7.7<->1C7.7 v7.7 1С7:ТиС Абонемент ($m)

Пример организации надёжной синхронизации данных через универсальный формат "EnterpriseData" между конфигурациями на базе 1С 7.7 и произвольными приложениями.

1 стартмани

07.01.2017    21853    24    binex    23    

"Распределение в запросе" или "избавляемся от перебора"

Математика и алгоритмы Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Хороший перебор - это отсутствие перебора. Рассмотрим пример замены полного перебора запросом.

16.12.2016    32713    0    alexandersh    48    

Разбираемся с механизмом Дополнительные отчеты и обработки в БСП

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Чуть более комплексное описание, чем на других ресурсах

1 стартмани

30.10.2016    140222    947    json    66    

Монитор журнала регистрации Промо

Журнал регистрации Администрирование данных 1С WEB v8 1cv8.cf Абонемент ($m)

Позволяет в режиме реального времени отслеживать активность пользователей, накапливать и оповещать о возникновении ошибок, которые попадают в журнал регистрации

2 стартмани

29.06.2015    39836    106    andy23    49    

Редактирование табличной части объекта с помощью СКД

Инструментарий разработчика Практика программирования v8::СКД 1cv8.cf Россия Абонемент ($m)

Тема не нова - похожие решения были и на 8.0. К написанию статьи меня подтолкнул коллега, т.к. я это чудом не считаю. Несколько раз я видел тонны сложнейшего, и посему нерабочего кода, целью которого было сделать нечто похожее средствами, которые для этого не предназначены. В статье дан простейший пример, показывающий, как можно применять средства СКД для редактирования сложной структуры данных, например, табличных частей документов. В частности, рассмотрена работа с набором данных типа "Объект" и событием "Обработка расшифровки"

2 стартмани

16.09.2016    24440    96    Hatson    27    

Примеры скриптов на OneScript

OneScript Россия Абонемент ($m)

В своей работе нам часто приходится заниматься рутинными операциями. При небольшом их объеме "ручное" выполнение еще допустимо, но с ростом их числа все мы задумываемся об автоматизации. Вот тут нам на помощь и приходят скрипты. На этом сайте уже выложено немало примеров различных скриптов, вот и я решил внести свою лепту.

1 стартмани

14.07.2016    28550    41    Drak0n    43    

Набор данных Объект в СКД для решения задач сортировки, нумерации и вывода в отчет произвольных наборов данных

Практика программирования v8::СКД 1cv8.cf Бесплатно (free)

Использование набора данных Объект в СКД, может добавить вашему отчету новые интересные возможности. В этой статье я покажу, как я использовал набор данных Объект при решении одной задачи.

04.07.2016    44607    0    lopatin    12    

Опыт оптимизации и контроля производительности в БД с 3000 пользователей Промо

Производительность и оптимизация (HighLoad) Бесплатно (free)

Данная статья написана по материалам доклада, прочитанного на Конференции Инфостарта IE 2014 29-31 октября 2014 года. Меня зовут Сергей, являюсь руководителем отдела оптимизации и производительности систем в компании "Деловые линии". Цель этого доклада – поделиться информацией о нашем опыте работы с большой базой на платформе 1С, с чем пришлось столкнуться, как удалось обеспечить работоспособность. Уверен, что вам будет интересно, так как подобной информацией мало кто делится, да и про само существование таких систем их владельцы стараются не рассказывать, максимум про это «краем глаза» упоминают участвовавшие в проекте вендоры. **update от 04.03.2016 по вопросам из комментариев

05.08.2015    60285    0    Sergey.Noskov    119    

Учет путевых листов

Обработка документов Печатные формы документов Учет рабочего времени Учет ТМЦ Учет рабочего времени Учет ТМЦ v8 v8::УФ 1cv8.cf БУ УУ Абонемент ($m)

Внешняя обработка по учету путевых листов для управляемых форм. Позволяет сохранять во внешнем файле данные об автомобилях, водителях и путевых листах. Позволяет печатать формы №3 и №4-П. Позволяет вести учет задолженностей водителей за бензин и сравнивать расход по норме (по показаниям спидометра) и фактический расход бензина.

3 стартмани

27.06.2016    14102    79    DrugOn    10    

Google Analytics API, Oauth2.0 и 1c8

Практика программирования WEB v8 1С:Франчайзи, автоматизация бизнеса Бесплатно (free)

Обращение к Google Analytics API, Протокол Oauth 2.0 и запросы от 1С:8 без авторизации пользователя

02.05.2016    25577    0    Ольга_tmp    18    

УПД для документа "Поступление товаров и услуг" (БП 3.0) за поставщика

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя печатная форма для документа "Поступление товаров и услуг" позволяет печатать "Универсальный передаточный документ (УПД)" за поставщика в ред. постановления Правительства РФ 1137, 625 и 981

1 стартмани

20.12.2015    21975    273    romanco    18    

Автоматический REST-сервис в «1С:Предприятии». OData. Пример работы из Jscript/AJAX Промо

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Небольшой обзор REST-сервиса в «1С:Предприятии». Рассмотрен механизм работы c REST-сервером 1С:Предприятия из внешнего приложения - веб-страницы с использованием языка JavaScript и технологии AJAX.

1 стартмани

08.10.2014    76567    75    vano-ekt    48    

Автозаполнение адресов в 1С (API Google autocomplete place)

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье вы увидите пример, как можно с помощью API Google autocomplete place делать подсказки при заполнении адреса

19.10.2015    12894    0    d.alexandr    26    

Использование встроенных отчетов для создания анализа корректности данных при исчислении НДС с авансов полученных

Бухгалтерский учет v8 БП2.0 Россия БУ НДС Бесплатно (free)

На Инфостарте много выложено внешних отчетов, направленных на контроль правильности исчисления НДС с авансов полученных. Хочу поделиться своим опытом использования встроенного отчета (для Бухгалтерия предприятия.Редакция 3.0) и порядка создания настроек отчета для процедур контроля за исчислением НДС с авансовых платежей покупателей, особенно в случаях применения различных налоговых ставок НДС

1 стартмани

22.07.2015    8768    0    lvk74    3    

Дополнительные отчеты и обработки для конфигураций, основанных на БСП. Часть 1. Заполнение объектов.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Абонемент ($m)

В статье приводится аргументация за использование во внешних отчетах и обработках только одного варианта использования - ОткрытиеФормы, и приводится пример обработки заполнения объекта, которая подключается к любой конфигурации ко всем объектам. Обработку легко отлаживать и можно использовать в качестве шаблона для создания других обработок заполнения объектов.

1 стартмани

08.01.2015    35018    72    acrk    23    

Создание внешних печатных форм под управляемым приложением с нуля Промо

Печатные формы документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Когда мне пришлось создавать внешние печатные формы под приложения на БСП ("1С: Бухгалтерия предприятия 3.0", "1С: Управление торговлей 11"), я обнаружил, что нет грамотных инструкций. Те, что имелись, использовали так называемые шаблоны: готовые обработки, в которых необходимо выполнять определенные корректировки. Но как создать сам шаблон, конкретных мануалов не было, справочную информацию я нашел на сайте ИТС и, обработав ее, написал статью, где подробно и понятно объясняются все этапы создания внешней печатной формы для управляемого приложения на примере конфигурации "1С: Бухгалтерия предприятия 3.0"

1 стартмани

05.06.2014    263229    391    signum2009    127    

Настройка ТСД chiperLab 8001 для УТ 11

Терминал сбора данных Учет ТМЦ Учет ТМЦ v8 УТ10 УУ Абонемент ($m)

Расширяем функционал ТСД chiperLab 8001 и загружаем сразу 10 документов Сканируйте 10 накладных за один раз!!!

1 стартмани

23.10.2014    24499    21    antonlinux    4    

Работа с принтером чеков Posiflex PP 6000, 7000, 8000

POS терминал Россия Абонемент ($m)

Некоторые варианты для работы с принтером чеков POSIFLEX AURA 6000, 7000, 8000.

1 стартмани

18.08.2014    64629    146    MrFlanker    24    

Подписываем файлы с помощью ЭЦП средствами 1с Промо

Универсальные обработки Защита и шифрование v8 1cv8.cf Абонемент ($m)

Обработка для подписи с помощью сертификата (ЭЦП) произвольных файлов, только средствами платформы 1с. Работает на всех конфигурациях, но только на последних платформах 8.2 и 8.3, где есть менеджер криптографии.

1 стартмани

05.09.2013    60514    255    anig99    25    

1С Бухгалтерия 8. Часть 1: Настройка параметров учета Промо

Управленческий учет (прочее) v8 БП2.0 Россия БУ Бесплатно (free)

Залогом правильного ведения бухгалтерского и налогового учета в программе 1С Бухгалтерия 8 является правильная настройка параметров учета и учетной политики. Разработчики 1С постарались, чтобы эти настройки были простыми и понятными. Тем не менее, есть ряд подводных камней, о которые могут спотыкаться даже опытные пользователи.

05.11.2011    223284    0    vdi1950    124