GGraphics - внешняя компонента для работы с картинками jpg (jpeg), png, bmp, gif, tif

Публикация № 74981

Разработка - Разработка внешних компонент

графика изображение редактирование картинка водяной знак масштабирование обрезание graphics image photo двоичные данные photoshop jpg jpeg bmp gif tiff bitmap png gimp

Позволяет автоматизировать работу с картинками. С помощью компоненты можно измерять размер изображений, поворачивать их, наносить водяные знаки, конвертировать из одного формата в другой. Будет очень полезна для интернет-магазинов и всех, кому постоянно требуется работать с различными графическими форматами. Выполнена по технологии NativeAPI. Работает с форматами: jpg (jpeg), png, bmp, gif, tif

Проект имеет следующие премущества:

  1. Не требует установки на каждом компьютере, где будет осуществляться обработка картинок
  2. Прекрасно работает даже с большими изображениями
  3. Скорость работы выше примерно на 40%
  4. Имеет малое потребление памяти
  5. Может работать на сервере

Демонстрация работы

Общие сведения

GGraphics – внешняя компонента для работы с картинками из 1С. Может использоваться для конвертации из одного формата в другой, получения изображения из буфера обмена, изменения размера изображения, поворота (отражения), обрезки, получения размеров, добавления водяного знака, сжатия.

Поддерживаемые операционные системы:
Windows XP, Windows 7,8 (x86,x64), Windows Server (x86,x64)

Работает в режимах:
Толстый клиент, Тонкий клиент, Сервер

Поддерживается работа со следующими форматами:
В режиме открытия:

  • bmp
  • jpg
  • png
  • gif
  • tiff

В режиме сохранения:

  • bmp
  • jpg
  • png
  • tiff


Форматы «водяного знака»:

  • bmp
  • jpg
  • png
  • gif

Описание свойств и методов


Свойства:

РазмерИзображения/ ImageSize – размер текущего изображения в формате "Ширина"x"Высота"(например, 300x550). Тип: Строка - Только чтение
Ширина/Width – ширина текущего изображения. Тип: Строка - Только чтение
Высота/Height – высота текущего изображения. Тип: Строка - Только чтение
Формат/Format – формат текущего изображения. Тип: Строка - Только чтение
КоличествоКадров/FrameCount – количество кадров для gif и tiff. Тип: Число - Только чтение
ДвоичныеДанные/ BinaryData – файл в формате jpg без сжатия. Тип: ДвоичныеДанные - Только чтение
Base64 – файл в формате jpg без сжатия представленный в виде строки Base64. Тип: Строка - Чтение и запись
ОписаниеОшибки / ErrorDescription - в случае возникновения ошибки, содержит её описание.

Методы:

1) ПолучитьИзображение / GetImage – получает изображение для обработки (конвертации) из файла или буфера обмена.

Параметры:

  • ИмяФайла - имя открываемого для редактирования файла. Если имя файла пустое, то изображение берется из буфера обмена. Тип: Строка

2) ПолучитьДвоичныеДанные / GetBinaryData – возвращает двоичные данные изображения в указанном формате

Параметры:

  • ТипФайла – формат файла, в котором необходимо вернуть двоичные данные. Тип: Число

Принимает следующие значения:

  • 0 – bmp
  • 1 – jpg
  • 2 – png
  • 3 - tif

3) ПолучитьBase64 / GetBase64 – возвращает данные изображения в указанном формате в виде строки Base64

Параметры:

  • ТипФайла – формат файла, в котором необходимо вернуть данные ихображения. Тип: Число

Принимает следующие значения:

  • 0 – bmp
  • 1 – jpg
  • 2 – png
  • 3 – tif

4) ОбрезатьИзображение / CropImage – обрезает изображение на указанную величину.
Параметры:

  • Лево - количество пикселей (процентов), обрезаемых слева. Тип: Число
  • Право - количество пикселей (процентов), обрезаемых справа. Тип: Число
  • Верх - количество пикселей (процентов), обрезаемых сверху. Тип: Число
  • Низ - количество пикселей (процентов), обрезаемых снизу. Тип: Число
  • ВПроцентах – признак того, что все величины указаны в процентах. Тип: Булево (для 7.7 - 0 и 1) 

5) ОбрезатьПустыеКрая / CropEmptyBorders – обрезает пустые (прозрачные) края изображения.
Параметры:

  • Отступ - количество пикселей, оставляемых в качестве отступа. Тип: Число

6) ПовернутьИзображение / RotateImage – поворачивает (отражает) текущее изображение.

Параметры:

  • ОтразитьПоГоризонтали – признак того, что изображение необходимо отразить по горизонтали. Тип: Булево
  • ОтразитьПоВертикали - признак того, что изображение необходимо отразить по вертикали. Тип: Булево
  • Поворот – поворот изображения (-1 – на 90 градусов против часовой, 1 – на 90 градусов по часовой). Тип: Число

7) ИзменитьРазмерИзображения / ResizeImage – изменяет размер изображения.

Параметры:

  • Ширина – новая ширина для изображения. Тип: Число
  • Высота – новая высота для изображения. Тип: Число
  • Процент – процент на который изменяется размер (если число отрицательное – уменьшение изображения, если положительное - увеличение). Тип: Число
  • СохранятьПропорции – признак того, что при изменении размера необходимо сохранить пропорции изображения. Если указано, что необходимо сохранить пропорции, то методу передается только один из параметров (либо шинира, либо высота), а второй параметр принимает нулевое значение. Тип: Булево (для 7.7 - 0 и 1).

8) ДобавитьВодянойЗнак / AddWatermark – добавляет на текущее изображение «водяной знак».
Параметры:

  • ИмяФайла – файл, который будет использоваться в качестве водяного знака. Тип: Строка
  • Позиция – позиция на текущем изображении, где необходимо разместить водяной знак. Тип: Число

Принимает следующие значения:

0 – сверху слева
1 – сверху центр
2 – сверху справа
3 – по центру
4 – снизу слева
5 – снизу центр
6 – снизу справа

  • Прозрачность – процент прозрачности накладываемого изображения. Изменяется от 0 до 100. При 100 – изображение непрозрачно. Тип: Число

9) РазмытиеПоГауссу/ GaussianBlur – применяет к текущему изображению эффект «РазмытиеПоГауссу».
Параметры:

  • Радиус – радиус размытия от 0 до 500. Тип: Число

10) НерезкоеМаскирование/ UnsharpMask – применяет к текущему изображению эффект «Нерезкое маскирование».
Параметры:

  • Радиус – радиус размытия от 0 до 500. Тип: Число
  • Интенсивность – интенсивность эффекта от 0 до 500. Тип: Число
  • Порог – порог срабатывания от 0 до 255. Тип: Число

11) УвеличитьРезкость/ Sharpen – увеличивает резкость текущего изображения.
Параметры:

  • Интенсивность – интенсивность эффекта от 0 до 100. Тип: Число

12) СделатьЧерноБелым / CreateBlackAndWhite – делает текущее изображение черно-белым (оттенки серого)

Параметры: Нет

13) Сепия/ Sepia – применяет к текущему изображению эффект «Сепия».
Параметры:

  • Интенсивность – интенсивность эффекта от 0 до 255. Тип: Число

14) ЗаполнитьПрозрачность / FillTransparent – заполняет прозрачные участки текущего изображения заданным цветом.
Параметры:

  • R – интенсивность красного цвета от 0 до 255. Тип: Число
  • G – интенсивность зеленого цвета. Тип: Число
  • B – интенсивность синего цвета. Тип: Число
  • СохранятьПолупрозрачность – при заполнении полупрозрачные участки будут залиты указанным цветом, но степень их прозрачности будет сохранена. Тип: Булево

15) УстановитьЦветТекста / SetTextColor – задает цветовые параметры для текста, добавляемого на изображение методом ДобавитьТекст / AddText.

Параметры:

  • R – интенсивность красного цвета от 0 до 255. Тип: Число
  • G – интенсивность зеленого цвета. Тип: Число
  • B – интенсивность синего цвета. Тип: Число
  • A – интенсивность альфа-канала (прозрачность) от 0 до 255. Тип: Число

16) УстановитьПараметрыТекста / SetTextParams – задает параметры шрифта для текста, добавляемого на изображение методом ДобавитьТекст / AddText.

Параметры:

  • ИмяШрифта – имя шрифта, установленного в системе. Тип: Строка
  • РазмерШрифта – размер шрифта в пунктах. Тип: Число
  • Жирный – признак полужирного шрифта. Тип: Булево
  • Курсив – наклонный шрифт. Тип: Булево
  • Подчеркнутый –подчеркнутый шрифт. Тип: Булево

17) ДобавитьТекст / AddText – добавляет на текущее изображение заданный текст.

Параметры:

  • X – координата по X для добавляемого текста. Тип: Число
  • Y – координата по Y для добавляемого текста. Тип: Число
  • Текст – текст, добавляемый на изображение. Тип: Строка

18) УстановитьТекущийКадр / SetAvtiveFrame – меняет текущий активный кадр изображения (для форматов gif и tiff).

Параметры:

  • НомерКадраномер кадра изображения, который необходимо сделать активным. Тип: Число

19) СохранитьИзображения / SaveImage – сохраняет изображение в файл на диске.

Параметры:

  • ИмяФайла – имя файла для сохранения на диске. Тип: Строка
  • ТипФайла – формат сохраняемого файла. Тип: Число

Принимает следующие значения:

  • 0 – bmp
  • 1 – jpg
  • 2 – png
  • 3 - tif
  • Сжатие – степень сжатия для файлов формата jpg. Тип: Число
  • УдалятьОригинал – признак того, что необходимо удалить оригинальный файл. Требуется, например, при конвертации из одного формата в другой. Тип: Булево (для 7.7 - 0 и 1)

20) Закрыть / Close – высвобождает память, занимаемую текущим изображением.

 

Примеры кода

1) Обработка изображения на сервере

&НаСервере
Функция СоздатьМиниатюру(ИсходныйФайл, ВыходнойФайл)

	ВысотаМиниатюры = 100;

	ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("ОбщийМакет.КомпонентаGGraphics", "Graphics", ТипВнешнейКомпоненты.Native);
			
	Если ПодключениеВыполнено Тогда					
		GGraphics = Новый("AddIn.Graphics.GGraphics");			
		GGraphics.ПолучитьИзображение(ИмяФайла);
		GGraphics.ИзменитьРазмерИзображения(0 , ВысотаМиниатюры, 0, Истина);
		GGraphics.СохранитьИзображение(ВыходнойФайл, 1, 100, Ложь);
		GGraphics.Закрыть();
	КонецЕсли;	
	
КонецФункции

 2) Обработка изображения на клиенте

&НаКлиенте
Функция ВозможноНанестиВодянойЗнак()

	РасположениеКомпоненты = "ОбщийМакет.КомпонентаGGraphics";
	ПодключениеВыполнено = ПодключитьВнешнююКомпоненту(РасположениеКомпоненты, "Graphics", ТипВнешнейКомпоненты.Native);
			
	Если НЕ ПодключениеВыполнено Тогда					
		УстановитьВнешнююКомпоненту(РасположениеКомпоненты);
		ПодключениеВыполнено = ПодключитьВнешнююКомпоненту(РасположениеКомпоненты, "Graphics", ТипВнешнейКомпоненты.Native);		
	КонецЕсли;	
	
	Возврат;
	
КонецФункции

&НаКлиенте
Процедура НанестиВодянойЗнак(ИмяФайла, ФайлВодяногоЗнака)

	Если ВозможноНанестиВодянойЗнак() Тогда
		GGraphics = Новый("AddIn.Graphics.GGraphics");			
		GGraphics.ПолучитьИзображение(ИмяФайла);
		GGraphics.ДобавитьВодянойЗнак(ФайлВодяногоЗнака, 3, 100);
		GGraphics.СохранитьИзображение(ИмяФайла, 1, 100, Ложь);
		GGraphics.Закрыть();
	КонецЕсли;

КонецПроцедуры

3) Обработка исключений

Попытка
   GGraphics.ПолучитьИзображение(ИмяФайла);
Исключение
   Сообщить(ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки, СтатусСообщения.Внимание);
КонецПопытки

Демонстрационная версия


В демонстрационной версии продукта только одно ограничение - все получаемые изображения имеют по центру надпись "DEMO".

Техническая поддержка

Срок бесплатной технической поддержки составляет 12 месяцев, начиная с даты приобретения продукта.

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Техподдержка 02.09.10 14:37
Исправил недочет с прозрачными областями png при наложении "водяного знака"
2. detec 129 02.09.10 14:38 Сейчас в теме
А какой командой добавлять компоненту в Windows?
3. Техподдержка 02.09.10 14:42
(2) regsvr32 <ПутьККомпоненте>
6. detec 129 02.09.10 16:02 Сейчас в теме
(3)

Спасибо! Так сейчас и сделал, При регистрации ошибок не было. Но всё равно не видит компоненту. Запускаю из толстого клиента, на Windows 7 x64. Я выполнял регистрацию из 32-битного cmd.exe
7. Техподдержка 02.09.10 16:05
(6) Файл компоненты должен лежать в каталоге исполняемых файлов 1С, либо
В ИмяФайла
ЗагрузитьВнешнююКомпоненту(<ИмяФайла>) 
должн быть указан полный путь к dll
9. detec 129 02.09.10 16:10 Сейчас в теме
(7) Попробовал зарегистрировать из 63-битного cmd.exe - не заработало. Только когда подкинул dll-ку в каталог 1С 8.2 - только тогда увидело её.

Но т.к. релизы 8.2 очень часто меняются - это паллиатив. Путь к dll-ке я, разумеется, указываю полный.
4. AlexBugs 02.09.10 15:12 Сейчас в теме
А в 7.7 точно работает? Может пример есть? :)
5. Техподдержка 02.09.10 16:01
(4) В 7.7 точно работает
ЗагрузитьВнешнююКомпоненту(<ПутьКВК>);
Graphics = СоздатьОбъект("AddIn.GraphicsVK")
8. Душелов 02.09.10 16:09 Сейчас в теме
Советую - работать с 1С-ными объектами типа "Картинка" (сделать 3 свойства для 7.7, 8.1 и 8.2 соответственно) и в зависимости от типа платформы возвращать готовый объект, без двоичных данных и промежуточных сохранений в файл.
10. Техподдержка 02.09.10 16:13
(8) В будущем так и сделаю
(7) Тут ничего не поделаешь, либо хранить в BIN, либо указывать полный путь.
Кажется, есть еще и третий вариант, но он муторный
11. detec 129 02.09.10 16:19 Сейчас в теме
Кажется, в демо-обработке есть баг. Я выбрал тип файлы - png, а после выбора пути сохранения мне выдало имя bmp.
12. Техподдержка 02.09.10 16:23
(11) Значит в поле "Файл для сохранения" было написано ***.bmp, хотя формат сохраненного файла при этом все равно будет png
13. Abadonna 3845 04.09.10 08:04 Сейчас в теме
(0) Как я понял из заголовка, ВК может работать и с 7.7.
Тогда вопрос: как задать в 7.7 тип Булево?
ВПроцентах – признак того, что все величины указаны в процентах. Тип: Булево

Нет его там вообще.
14. Техподдержка 04.09.10 10:56
(13) Все просто, для 7.7 будет так:
0 - Ложь
Не нуль - Истина
15. Abadonna 3845 04.09.10 10:58 Сейчас в теме
(14) У тебя ж не написано, что параметр вариантный, вот я и спросил.
Допиши в описание
16. Murom 06.09.10 14:55 Сейчас в теме
Компонента то, что надо. Давно искал что-то подобное т.к. не хотелось мутить через COM.
17. Техподдержка 06.09.10 15:12
(16) Форматы «водяного знака»:

* bmp
* jpg
* png

Сохрани как png c прозрачностью и все должно стать хорошо
18. Murom 07.09.10 16:56 Сейчас в теме
Есть еще вопрос!
Открываю png с прозрачным фоном, меняю размер изображения (растягиваю водяной знак ) потом сохраняю ... и получаю что прозрачный фон заменен на белый.

вкФайлКопирайта.ИзменитьРазмерИзображения(Ширина, Высота, 0, Ложь);
вкФайлКопирайта.СохранитьИзображение("tmp.png", 2, 0, Ложь);

Можно как нибудь сделать , чтоб прозрачный фон сохранялся?
19. Техподдержка 07.09.10 17:34
(18) К сожалению png пока не получится записать, сохранив при этом прозрачность. В будущем надеюсь это исправить.
22. Murom 09.09.10 00:24 Сейчас в теме
(19) Ну, тогда будем ждать новую версию с сохранением прозрачного фона в png.
PS . Реально очень сильно не хватало в 1с функций для преобразования графических файлов.
103. 1CLeXx 8 11.05.14 00:45 Сейчас в теме
Здравствуйте, подскажите плиз, почему ругается:

Код

GraphicsVK = СоздатьОбъект("AddIn.GraphicsNET");
GraphicsVK.ПолучитьИзображение("C:/301fbfeead21.jpg");

Изображение присутствует, но выдает ошибку:

GraphicsVK.ПолучитьИзображение("C:/301fbfeead21.jpg");
{C:\GFX.ERT(23)}: Поле агрегатного объекта не обнаружено (ПолучитьИзображение)

Что не так делаю?

Спасибо!
(103) Скорее всего проблема в самом компоненте. Метод "СоздатьОбъект" не вызывает ошибки? Попробуйте выполнить unreg.bat и reg.bat
105. 1CLeXx 8 12.05.14 11:51 Сейчас в теме
(104), да, действительно данные манипуляции помогли решить проблему.
Спасибо
45. Техподдержка 22.09.10 11:39
(22) Попробуйте новую версии программы (добавил сохранение прозрачности фона у png)
20. DimaP 56 07.09.10 18:38 Сейчас в теме
Плюс - задолался с этим ИмейджМэджик - нифига не работает, аналогично с остальными утилистами консольного преобразования изображений.
Вот только оно как-то долго работает ... :(
24. sarumanchik 09.09.10 16:19 Сейчас в теме
спасибо, компонента очень выручила ! желаю дальнейшего развития проекта ! ))
26. Altair777 640 09.09.10 16:33 Сейчас в теме
В архиве лежит Тест1CGraphics.epf
а для 7-ки можно?
27. Техподдержка 09.09.10 16:35
(26) Нет, для семерки пример делать нет времени, но там все абсолютно тоже самое.
28. Murom 09.09.10 18:09 Сейчас в теме
При наложении в цикле водяного знака (при вызове ДобавитьВодянойЗнак) течет память.
Потом показывается ошибка
GraphicsVK : Some operation could not be performed because the system is out of resources. Close some windows and try again..
Потом
GraphicsVK : Access violation at address 073932D4 in module 'GraphicsVK.dll'. Write of address 00000000 и еще что-то.
И вылетает 1с. Файл подкачки вырастает почти на 1 гб...
Если надо могу пример обработки под 8.1.

36. Техподдержка 14.09.10 17:09
(28) Добавил метод "Закрыть()"
При вызове метода высвобождается память занимаемая объектом.
Т.е. порядок работы следующий
Компонента.ПолучитьИзображение(...);
// Различные манипуляции с изображением
Компонента.xxxx();
Компонента.xxxx();
Компонента.СохранитьИзображение(...);
Компонента.Закрыть();
30. iceflash 4 10.09.10 16:05 Сейчас в теме
На чем написана компонента? (с целью подсказать возможные проблемы/улучшения)
32. iceflash 4 10.09.10 17:04 Сейчас в теме
Так и подумал, но решил уточнить=) Используешь что для работы с изображениями? TJpegImage (вроде так называется) и Tbitmap или стороннее что то?
33. Техподдержка 10.09.10 17:10
(32) Используется много чего.
Для хранения текущего изображения TBitmap
Для открытия различных форматов TPicture и TGIFImage (RXLib модуль rxgif)
При сохранении в jpg TJPEGImage
При работе с png используется TPNGObject (модуль pngimage)
34. iceflash 4 10.09.10 17:24 Сейчас в теме
Насколько помню вот так с ходу:
1. Не используй Tbitmap
2. Преобразования и битовые операции делай через BitBlt и маски
3. Все перечисленные объекты должны позволять работать не использая Bitmap
4. Самое узкое место всегда тут будет Tbitmap , пробуй указатели либо там есть еще какой то "тип" данных (не помню уже точно) - это даст экономию памяти, а использование процедур апи и работы с маской значительный прирост=)
35. Техподдержка 10.09.10 17:26
(34) Спасибо! Буду пробовать различные варианты
37. msw2010 14.09.10 18:35 Сейчас в теме
Не получилось работать с emf/emz (стандартные форматы Офиса)
38. Техподдержка 14.09.10 18:38
(37) Пока работа с emf поддерживается только если изображение находится в буфере обмена. Постараюсь добавить поддержку и в режиме открытия из файла
39. Техподдержка 15.09.10 11:16
Добавил поддержку форматов emf и wmf в режиме открытия из файла
40. msw2010 16.09.10 09:49 Сейчас в теме
пробовал открыть emf через тест: ошибок не даёт, размеры картинки правильные, картинка пустая :(
41. Техподдержка 16.09.10 09:52
(40) Сбросте файл на "alxd" собачка "inbox.ru", я посмотрю
161. mchammer4 103 20.06.17 21:51 Сейчас в теме
// Процедуры обработки изображений

Функция ВыполнитьОбработкуИзображений(ПутьКФайлуНаСервере, Сценарий, КаталогФайлов = "", Префикс = "") Экспорт

Файл = Новый Файл(ПутьКФайлуНаСервере);
Если Не Файл.Существует() Тогда
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "Не найден файл """ + ПутьКФайлуНаСервере + """ !");
Возврат Неопределено;
КонецЕсли;

ПодключениеВыполнено = Ложь;

// Компонента для работы с картинками
ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("ОбщийМакет.МДК_GGraphics", "Graphics", ТипВнешнейКомпоненты.Native);
Если ПодключениеВыполнено Тогда
Попытка
GGraphics = Новый("AddIn.Graphics.GGraphics");
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "Не удалось подключить компоненту ""AddIn.Graphics.GGraphics"" по причине: " + ОписаниеОшибки());
ПодключениеВыполнено = Ложь;
КонецПопытки;
Иначе
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "Не удалось подключить компоненту ""AddIn.Graphics.GGraphics"" !");
ПодключениеВыполнено = Ложь;
КонецЕсли;

// Компонента для замены фона картинки
Попытка
ImageTools = Новый COMОбъект("Graphic.ImageTools");
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "Не удалось подключить компоненту ""Graphic.ImageTools"" по причине: " + ОписаниеОшибки());
ПодключениеВыполнено = Ложь;
КонецПопытки;

Если Не ПодключениеВыполнено Тогда
Возврат Неопределено;
КонецЕсли;

// Получение двоичных данных
ЕстьДанные = Ложь;

Попытка
GGraphics = Новый("AddIn.Graphics.GGraphics");
GGraphics.ПолучитьИзображение(ПутьКФайлуНаСервере);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
ЕстьДанные = Истина;
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
КонецПопытки;

Если Не ЕстьДанные Тогда
Возврат Неопределено;
КонецЕсли;

// Выполнение последовательности действий по схеме
Для Каждого Строка Из Сценарий.ПоследовательностьВыполнения Цикл
ДвоичныеДанные = ВыполнитьПреобразование(Строка.Алгоритм, ДвоичныеДанные, Сценарий, Файл.Имя);
Если ДвоичныеДанные = Неопределено Тогда
Прервать; // выход по ошибке
КонецЕсли;
КонецЦикла;

// Выходной файл
Если ДвоичныеДанные = Неопределено Тогда
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "Неудачная попытка выполнения сценария """ + СокрЛП(Сценарий) + """");
Возврат Неопределено;

Иначе // Сохранение результата
Если ПустаяСтрока(КаталогФайлов) Тогда
КаталогФайлов = КаталогВременныхФайлов();
КонецЕсли;

ФайлДляСохранения = КаталогФайлов + "\" + СокрЛП(Префикс) + Файл.Имя;

Попытка
GGraphics = Новый("AddIn.Graphics.GGraphics");
GGraphics.Base64 = Base64Строка(ДвоичныеДанные);
ТипФайла = Сценарий.ТипФайла;
Сжатие = Сценарий.Сжатие;
GGraphics.СохранитьИзображение(ФайлДляСохранения, ТипФайла, Сжатие, Ложь);
GGraphics.Закрыть();

Возврат ФайлДляСохранения; // ОБРАБОТАННОЕ ИЗОБРАЖЕНИЕ!!!

Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);

КонецПопытки;

КонецЕсли;

Возврат Неопределено;

КонецФункции

Функция ВыполнитьПреобразование(Алгоритм, ДвоичныеДанные, Сценарий, ИмяФайла)

Попытка
GGraphics = Новый("AddIn.Graphics.GGraphics");
GGraphics.Base64 = Base64Строка(ДвоичныеДанные);
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ДвоичныеДанные: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

Если Алгоритм = "ЗаменитьФон" Тогда
ФайлДляСохранения = ПолучитьИмяВременногоФайла("") + "_" + ИмяФайла;
Попытка
ТипФайла = Сценарий.ТипФайла;
Сжатие = Сценарий.Сжатие;
GGraphics.СохранитьИзображение(ФайлДляСохранения, ТипФайла, Сжатие, Ложь);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ЗаменитьФон: " + ОписаниеОшибки()+ ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;
ФайлФона = Сценарий.ФайлФона;
ДиапазонПрозрачностиКрасный = Сценарий.ДиапазонПрозрачностиКрасный;
ДиапазонПрозрачностиЗеленый = Сценарий.ДиапазонПрозрачностиЗеленый;
ДиапазонПрозрачностиСиний = Сценарий.ДиапазонПрозрачностиСиний;
Попытка
ImageTools = Новый COMОбъект("Graphic.ImageTools");
Дескриптор = ImageTools.Open(ФайлФона);
ДиапазонПрозрачности = ImageTools.Color(ДиапазонПрозрачностиКрасный, ДиапазонПрозрачностиЗеленый, ДиапазонПрозрачностиСиний);
ImageTools.Transparent(Дескриптор, ФайлДляСохранения, -1, ДиапазонПрозрачности);
ImageTools.SaveAs(Дескриптор, ФайлДляСохранения);
ImageTools.Close(Дескриптор);
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ЗаменитьФон: " + ОписаниеОшибки());
Возврат Неопределено;
КонецПопытки;
Попытка
GGraphics = Новый("AddIn.Graphics.GGraphics");
GGraphics.ПолучитьИзображение(ФайлДляСохранения);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
УдалитьФайлы(ФайлДляСохранения);
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ЗаменитьФон: " + ОписаниеОшибки()+ ": " + GGraphics.ОписаниеОшибки);
УдалитьФайлы(ФайлДляСохранения);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ОтразитьПоВертикали" Тогда
Попытка
GGraphics.ПовернутьИзображение(Ложь, Истина, 0);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ОтразитьПоВертикали: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ОтразитьПоГоризонтали" Тогда
Попытка
GGraphics.ПовернутьИзображение(Истина, Ложь, 0);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ОтразитьПоГоризонтали: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ПовернутьПоЧС" Тогда
Попытка
GGraphics.ПовернутьИзображение(Ложь, Ложь, 1);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ПовернутьПоЧС: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ПовернутьПротивЧС" Тогда
Попытка
GGraphics.ПовернутьИзображение(Ложь, Ложь, -1);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ПовернутьПротивЧС: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ПоворотНаПроизвольныйГрадус" Тогда
УголВГрадусах = Сценарий.УголВГрадусах;
ЦветФонаВУглах_Красный = Сценарий.ЦветФонаВУглах_Красный;
ЦветФонаВУглах_Зеленый = Сценарий.ЦветФонаВУглах_Зеленый;
ЦветФонаВУглах_Синий = Сценарий.ЦветФонаВУглах_Синий;
Попытка
ImageTools = Новый COMОбъект("Graphic.ImageTools");
Строка64 = Base64Строка(ДвоичныеДанные);
РезСтрока64 = ImageTools.RotateBase64(Строка64,
УголВГрадусах,
ImageTools.Color(ЦветФонаВУглах_Красный,
ЦветФонаВУглах_Зеленый,
ЦветФонаВУглах_Синий));
ДвоичныеДанные = Base64Значение(РезСтрока64);
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ПоворотНаПроизвольныйГрадус: " + ОписаниеОшибки());
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ОбрезатьПустыеКрая" Тогда
ОтступПустыеКрая = Сценарий.ОтступПустыеКрая;
Попытка
GGraphics.ОбрезатьПустыеКрая(ОтступПустыеКрая);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ОбрезатьПустыеКрая: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "Обрезать" Тогда
КоличествоСлева = Сценарий.КоличествоСлева;
КоличествоСправа = Сценарий.КоличествоСправа;
КоличествоСверху = Сценарий.КоличествоСверху;
КоличествоСнизу = Сценарий.КоличествоСнизу;
ОбрезатьВПроцентах = Сценарий.ОбрезатьВПроцентах;
Попытка
GGraphics.ОбрезатьИзображение(КоличествоСлева, КоличествоСправа, КоличествоСверху, КоличествоСнизу, ОбрезатьВПроцентах);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "Обрезать: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "УвеличитьРазмерНаПроцент" Тогда
ПроцентУвеличения = Сценарий.ПроцентУвеличения;
Попытка
GGraphics.ИзменитьРазмерИзображения(0, 0, ПроцентУвеличения, Истина);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "УвеличитьРазмерНаПроцент: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "УменьшитьРазмерНаПроцент" Тогда
ПроцентУменьшения = Сценарий.ПроцентУменьшения;
Попытка
GGraphics.ИзменитьРазмерИзображения(0, 0, (-1)*ПроцентУменьшения, Истина);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "УменьшитьРазмерНаПроцент: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "УстановитьШиринуПропорционально" Тогда
ПропорциональноПоШирине = Сценарий.ПропорциональноПоШирине;
Попытка
GGraphics.ИзменитьРазмерИзображения(ПропорциональноПоШирине, 0, 0, Истина);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "УстановитьШиринуПропорционально: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "УстановитьВысотуПропорционально" Тогда
ПропорциональноПоВысоте = Сценарий.ПропорциональноПоВысоте;
Попытка
GGraphics.ИзменитьРазмерИзображения(0, ПропорциональноПоВысоте, 0, Истина);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "УстановитьВысотуПропорционально: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "УстановитьРазмер" Тогда
БезПропорцийШирина = Сценарий.БезПропорцийШирина;
БезПропорцийВысота = Сценарий.БезПропорцийВысота;
Попытка
GGraphics.ИзменитьРазмерИзображения(БезПропорцийШирина, БезПропорцийВысота, 0, Ложь);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "УстановитьРазмер: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ДобавитьТекст" Тогда
R = Сценарий.Текст_Цвет_Красный;
G = Сценарий.Текст_Цвет_Зеленый;
B = Сценарий.Текст_Цвет_Синий;
Текст_Прозрачность = Сценарий.Текст_Прозрачность;
Текст_Шрифт = Сценарий.Текст_Шрифт;
Текст_Размер = Сценарий.Текст_Размер;
Текст_Жирный = Сценарий.Текст_Жирный;
Текст_Курсив = Сценарий.Текст_Курсив;
Текст_Подчеркнутый = Сценарий.Текст_Подчеркнутый;
Текст_X = Сценарий.Текст_X;
Текст_Y = Сценарий.Текст_Y;
Текст_Текст = Сценарий.Текст_Текст;
Попытка
GGraphics.УстановитьЦветТекста(R, G, B, Текст_Прозрачность);
GGraphics.УстановитьПараметрыТекста(Текст_Шрифт, Текст_Размер, Текст_Жирный, Текст_Курсив, Текст_Подчеркнутый);
GGraphics.ДобавитьТекст(Текст_X, Текст_Y, Текст_Текст);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ДобавитьТекст: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ЗаполнитьПрозрачность" Тогда
R = Сценарий.ЗаполнениеПрозрачности_Цвет_Красный;
G = Сценарий.ЗаполнениеПрозрачности_Цвет_Зеленый;
B = Сценарий.ЗаполнениеПрозрачности_Цвет_Синий;
Попытка
GGraphics.ЗаполнитьПрозрачность(R, G, B);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ЗаполнитьПрозрачность: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ВыполнитьРазмытиеПоГауссу" Тогда
Размытие_Радиус = Сценарий.Размытие_Радиус;
Попытка
GGraphics.РазмытиеПоГауссу(Размытие_Радиус);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ВыполнитьРазмытиеПоГауссу: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ВыполнитьНерезкоеМаскирование" Тогда
UnsharpMask_Радиус = Сценарий.UnsharpMask_Радиус;
UnsharpMask_Сила = Сценарий.UnsharpMask_Сила;
UnsharpMask_Порог = Сценарий.UnsharpMask_Порог;
Попытка
GGraphics.НерезкоеМаскирование(UnsharpMask_Радиус, UnsharpMask_Сила, UnsharpMask_Порог);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ВыполнитьНерезкоеМаскирование: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ЭффектЧерноБелого" Тогда
Попытка
GGraphics.СделатьЧерноБелым();
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ЭффектЧерноБелого: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ЭффектСепия" Тогда
Попытка
GGraphics.ЭффектСепия(40);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ЭффектСепия: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "НанестиВодянойЗнак" Тогда
ФайлВЗ = Сценарий.ФайлВЗ;
РасположениеВодяногоЗнака = Сценарий.РасположениеВодяногоЗнака;
ПрозрачностьЗнака = Сценарий.ПрозрачностьЗнака;
Попытка
GGraphics.ДобавитьВодянойЗнак(ФайлВЗ, РасположениеВодяногоЗнака, ПрозрачностьЗнака);
ТипФайла = Сценарий.ТипФайла;
ДвоичныеДанные = GGraphics.ПолучитьДвоичныеДанные(ТипФайла);
GGraphics.Закрыть();
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "НанестиВодянойЗнак: " + ОписаниеОшибки() + ": " + GGraphics.ОписаниеОшибки);
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "НаложитьИзображение" Тогда
ФайлИзображенияНаложения = Сценарий.ФайлИзображенияНаложения;
Попытка
ImageTools = Новый COMОбъект("Graphic.ImageTools");
Строка64 = Base64Строка(ДвоичныеДанные);
Строка64_1 = Base64Строка(Новый ДвоичныеДанные(ФайлИзображенияНаложения));
РезСтрока64 = ImageTools.DrawCenterBase64(Строка64, Строка64_1);
ДвоичныеДанные = Base64Значение(РезСтрока64);
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "НаложитьИзображение: " + ОписаниеОшибки());
Возврат Неопределено;
КонецПопытки;

ИначеЕсли Алгоритм = "ЗаменитьЦвета" Тогда
ФайлИзображенияНаложения = Сценарий.ФайлИзображенияНаложения;
Попытка
ImageTools = Новый COMОбъект("Graphic.ImageTools");
Строка64 = Base64Строка(ДвоичныеДанные);
ЦветоваяЗаменаСтрока = "";
Для Каждого Стр Из Сценарий.ЦветоваяЗамена Цикл
ЦветоваяЗаменаСтрока = ЦветоваяЗаменаСтрока + Строка(ImageTools.Color(Стр.ЗаменяемыйЦвет_Красный,Стр.ЗаменяемыйЦвет_Зеленый,Стр.ЗаменяемыйЦвет_Синий))
+ "," + Строка(ImageTools.Color(Стр.ДиапазонОтклонения_Красный,Стр.ДиапазонОтклонения_Зеленый,Стр.ДиапазонОтклонения_Синий))
+ "," + Строка(ImageTools.Color(Стр.НовыйЦвет_Красный,Стр.НовыйЦвет_Зеленый,Стр.НовыйЦвет_Синий)) + ",";
КонецЦикла;
РезСтрока64 = ImageTools.ChangeColorsBase64(Строка64, ЦветоваяЗаменаСтрока);
ДвоичныеДанные = Base64Значение(РезСтрока64);
Исключение
ЗаписьЖурналаРегистрации(НСтр("ru = 'Обработка изображений для сайта'",
ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
УровеньЖурналаРегистрации.Ошибка,,, "ЗаменитьЦвета: " + ОписаниеОшибки());
Возврат Неопределено;
КонецПопытки;

КонецЕсли;

Возврат ДвоичныеДанные;

КонецФункции
42. msw2010 21.09.10 15:29 Сейчас в теме
очень хочется поддержку emf ;)
43. Техподдержка 21.09.10 15:34
(42) Практически готова новая версия компоненты (написана с нуля и на др. языке), которая будет полностью поддерживать emf. Скоро размещу здесь. Если есть желание могу дать потестить ;)
46. msw2010 24.09.10 21:25 Сейчас в теме
Спасибо большое! Работает нормально. ;)
47. maljaev 793 01.10.10 10:30 Сейчас в теме
Про библиотеку GflAx не забывайте. В ней функционала-то поболее будет. Хотя я и приветствую новые разработки, если в них действительно что-то новое есть, а так какой смысл изобретать велосипед.
48. Техподдержка 01.10.10 10:41
(47) Видел я эту библиотеку. Да функционал у нее богаче, НО!
1) С ее помощью не нашел как добавлять без заморочек водяной знак
2) GraphicsNET - лишь часть (которой решил поделится) большой компоненты , используемой в моей конфигурации.
Согласитесь, удобнее пользоваться одной компонентой и, что не мало важно, дорабатывать ее функционал, чем использовать несколько различных решений.
50. maljaev 793 01.10.10 12:26 Сейчас в теме
(48) Можно добавить водяной знак, с заморочками или без - это уж от опыта использования зависит. А вот насчет большой компоненты - это интересненько, можешь хотя бы вкратце сказать что туда входит? Выкладывать демку в широкие массы не собираешься?
51. Техподдержка 01.10.10 12:35
(50) Выкладывать не собираюсь. Просто собрал в одном месте все необходимые для работы данной конфы полезности, ну например, получение хеша MD5, быстрое извлечение данных из очень большого XML (700-800 мб) в txt, и т.п.
56. Pilokarpios 33 18.02.11 13:53 Сейчас в теме
Хелп, протестил компоненту 1С 8.2. все работает!

а на 1С 77 не работает, что может быть?

ЗагрузитьВнешнююКомпоненту(ПолныйПутьККомпоненте);
ГрафикаВК = СоздатьОбъект("AddIn.GraphicsNET");

Пока Цикл

   ГрафикаВК.ПолучитьИзображение(ПутьКФайлуИсточник);
   Размер = Число(-30);
   ГрафикаВК.ИзменитьРазмерИзображения(ГрафикаВК.Ширина,,Размер,1);
   Сжатие = Число(50);
   ТипФайла = "jpg";
   ГрафикаВК.СохранитьИзображение(ПутьКФайлуСохранение,ТипФайла,Сжатие,0);

КонецЦикла;

ГрафикаВК.Закрыть();
Показать


Повторюсь, на 1с82 на том же компе работает
57. Техподдержка 18.02.11 14:12
(56) Во-первых, вместо
ЗагрузитьВнешнююКомпоненту(ПутьКФайлуИсточник);

следует писать
ПодключитьВнешнююКомпоненту("AddIn.GraphicsNET");


И еще, метод СохранитьИзображение во втором параметре принимает не стороку, а число
0 – bmp
1 – jpg
2 – png

И все будет работать
49. Техподдержка 01.10.10 10:49
Исправил ошибку с вычислением координат водяного знака, когда он размещается в центре изображения
52. mevgenym 85 01.10.10 13:09 Сейчас в теме
В обработке. "Уменьшить на" действует только на ширину, причем иногда и пропорционально, примерно с третьего подрят клика начинает уменьшать только ширину.
53. Техподдержка 01.10.10 13:16
(52) Действительно, есть косяк с потерей пропорциональности. Исправлю. Спасибо за наблюдательность!
54. Поручик 4375 04.02.11 00:32 Сейчас в теме
При получении изображения из буфера обмена ПолучитьИзображение("") выскакивает раздражающее окно. Нельзя ли его выбросить нафиг?
Второй вопрос по поводу использования библиотеки в составе сторонних обработок.
55. Техподдержка 09.02.11 16:06
(54) По поводу окна проверю.
А в составе сторонних обработок можете пользовать сколько душе угодно
80. Поручик 4375 23.08.12 20:31 Сейчас в теме
(55) При получении изображения из буфера обмена ПолучитьИзображение("") выскакивает раздражающее окно. Нельзя ли его выбросить нафиг?
Сколько денег дать на перекомпиляцию библиотеки?
84. Техподдержка 24.08.12 08:59
(80) Деньги!? Нее, не слышал )))
Перезалил. Скачайте еще раз
85. Поручик 4375 24.08.12 20:38 Сейчас в теме
(84) Вот это другое дело.
Но теперь не удаётся зарегистрировать компоненту на Windows 7 корпоративной (64 бит). Библиотеку засунул в каталог bin 1С Предприятия
Команда регистрации: regsvr32 "C:\Program Files (x86)\1cv82\8.2.15.319\bin\GraphicsNET.dll" выполняю под админскими правами.
Прикрепленные файлы:
86. Техподдержка 24.08.12 22:00
(85) Регистрируется через файл reg.bat, который находится в архиве. При этом файл RegAsm.exe тоже должен быть распакован в каталог с компонентой и батником
87. Поручик 4375 24.08.12 22:18 Сейчас в теме
(86) В этом случае выдётся сообщение, что RegAsm.exe не является исполняемым файлом. Скрин
Прикрепленные файлы:
88. Поручик 4375 24.08.12 22:22 Сейчас в теме
(86) Указываю полные абсолютные пути. Скрин
Прикрепленные файлы:
58. Pilokarpios 33 18.02.11 14:16 Сейчас в теме
ок, спасибо,работает, воспользовался GraphicsVK, её проще удаленно зарегистрировать regsvr32
59. Техподдержка 18.02.11 14:21
(58) Вот только функционалом она не блещет :)
60. Pilokarpios 33 18.02.11 14:32 Сейчас в теме
Мне главное сжать размер до 10%, остальное неважно

Есть проблема,

Пользуюсь все же:

ЗагрузитьВнешнююКомпоненту("GraphicsVK.dll");
ГрафикаВК = СоздатьОбъект("AddIn.GraphicsVK");


Все работает, но, пока программу не завершить (1cv77.exe), папка сохранения фотографий залочена компонентой, не удалить.

Даже если:

Процедура ПриЗакрытии()
ГрафикаВК = 0;
КонецПроцедуры
61. Техподдержка 18.02.11 14:45
(61) А вот это нехорошо, конечно. Посмотрю, как будет время
63. cool.vlad4 44 08.09.11 16:03 Сейчас в теме
Есть золотая библиотека cxImage к которой также написаны ActiveX. Не требует dotnet. Советую для конвертирования, изменения, сжатия изображений.
64. vitalya24 226 09.09.11 03:13 Сейчас в теме
очень полезная штука, автору респект. Не очень удобно что нет метода который бы выводил размер файла картинки, хоть в 1с и есть такой метод, но здесь было бы удобнее
65. Техподдержка 09.09.11 08:31
(64) Спасибо! Если все таки дойдут руки до расширения функционала, обязательно добавлю этот метод.
66. prophetic 07.11.11 09:57 Сейчас в теме
Благодарю за компоненту. Используется на живую для обработки выгрузки из 1С на веб-сайт. Успехов!
67. suneagle 14.11.11 11:14 Сейчас в теме
Хорошая компонента, но у меня не получилось ее запустит на сервере.
Насколько я понимаю загвоздка в:
ПодключитьВнешнююКомпоненту("AddIn.GraphicsNET");

В таком виде запуск на сервере не возможен, а как изменить для регистрации на сервере так и не разобрался. Для данной библиотеки это возможно?
68. Техподдержка 14.11.11 19:22
(67) Нет, данная библиотека не будет работать на сервере
69. a_mironov 11.12.11 04:40 Сейчас в теме
71. ErrorEd88 47 30.01.12 18:59 Сейчас в теме
У меня есть одна УТшка, где 7000 наименований номенклатуры и все с картинками. База файловая, очень сильно тормозит. Поможет ли мне эта разработка ускорить работу базы?
72. Техподдержка 30.01.12 19:12
(71) Эта компонента может помочь автоматизировать процесс сжатия(ресайзинга) изображений, что поможет уменьшить размер базы. Но вообще хранить 7000 картинок в файловой базе, по-моему, кощунство
73. ErrorEd88 47 30.01.12 19:42 Сейчас в теме
74. Denis_Shiln 01.02.12 15:34 Сейчас в теме
Не могу подключить к 7-ке. Windows XP, DLL-ка находится в BIN 1С-ки
на
ПодключитьВнешнююКомпоненту(GraphicsNET.dll);
GraphicsVK = СоздатьОбъект("AddIn.GraphicsVK");


Ошибка при создании объекта из компоненты <Неизвестная компонента> (отсутствует CLSID)
GraphicsVK = СоздатьОбъект("AddIn.GraphicsVK");
{F:\BASE\...\PRICE.ERT(975)}: Неудачная попытка создания объекта (AddIn.GraphicsVK)

а на
ЗагрузитьВнешнююКомпоненту(GraphicsNET.dll);
GraphicsVK = СоздатьОбъект("AddIn.GraphicsVK");


Ошибка при создании объекта из компоненты C:\Program Files\1Cv77\BIN\GraphicsNET.dll (отсутствует интерфейс IInitDone)
GraphicsVK = СоздатьОбъект("AddIn.GraphicsVK");
{F:\BASE\...\PRICE.ERT(977)}: Неудачная попытка создания объекта (AddIn.GraphicsVK)
75. Техподдержка 01.02.12 15:55
(74)
ЗагрузитьВнешнююКомпоненту(<ПутьКDLL>);
Graphics = СоздатьОбъект("AddIn.GraphicsNET");
Denis_Shiln; +1 Ответить
76. astars 02.08.12 11:22 Сейчас в теме
Спасибо за компоненту. Планируется ли сделать возможным её запуск на сервере?
78. umetex 02.08.12 12:07 Сейчас в теме
(76) astars, Думаю, вообще невозможно. Компонента написана под .net (c#), а на сервере компоненты могут работать только в том случае, если они написаны на c++ no CLR по технологии NativeAPI. Не думаю, что автор с удобного c# перейдёт на c++ для переноса либы :)
79. Техподдержка 02.08.12 12:31
(78) Именно поэтому и маловероятно :)
81. CheBurator 3410 24.08.12 01:30 Сейчас в теме
Хочу: интеллектуальную обрезку!
На вход подсовываем файл изображения.
Изображение что-то там на однородном фоне. Фон намного больше собственно содержательного изображения.
На выходе - получаем обрезанный файл, который содержит собственно содержательное изображение с некоторым отсупом по сторонам прямоугольника с фоном -т.е. выкидываем нафиг из большого изображения все, что равно лишнему фону.
82. CheBurator 3410 24.08.12 01:33 Сейчас в теме
для ряда задач можно успешно заюзать http://infostart.ru/public/15599/
89. Поручик 4375 24.08.12 22:28 Сейчас в теме
Вот только так и получилось.
90. Sirruf 138 20.11.13 13:02 Сейчас в теме
Неприятная ошибка при попытке наложения водяного знака:
"Невозможно создать объект графики из изображения, имеющего формат с индексированными точками."
Пример картинки http://cdn0.sima-land.ru/items/726/726045/0/1600.jpg
91. Техподдержка 20.11.13 13:44
(90) Можно исходное изображение посмотреть и водяной знак?
92. Sirruf 138 20.11.13 14:39 Сейчас в теме
93. Техподдержка 21.11.13 09:41
(92) Оперативно решить проблему не получается. Могу посоветовать следующий выход:
Сначала получаете изображение (в данном конкретном случае 1600.jpg), затем сохраняете его (опять же с помощью компоненты). Потом снова получаете уже сохраненное изображение, и наносите на него водяной знак.
94. Sirruf 138 21.11.13 09:55 Сейчас в теме
95. mzelensky 53 18.12.13 10:22 Сейчас в теме
Вопрос - можно ли сделать наложение водяного знака не через "Сверху\снизу\по центру", а через указание координакт. Ну или скажем в процентах от верхнего левого угла, те. например, 90%*50% (что означает наложить знакт на 90% вниз от верхнего угла и на 50% вправо от левого угла).

Было бы очень здорово!
97. mzelensky 53 18.12.13 11:23 Сейчас в теме
(96) Спасибо! Постараюсь не пропустить обновление обработки.
Оставьте свое сообщение

См. также

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

SALE! 10%

Внешняя компонента клиента SSH / SCP (Native API)

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 Платные (руб) Разработка внешних компонент

Внешняя компонента, выполненная по технологии NativeAPI, для взаимодействия с удаленными серверами по протоколу SSH, обмена файлами по протоколу SCP и возможностью перенаправления портов через SSH туннель.

5000 руб.

18.06.2019    3602    14    0       

SALE! 10%

Компонента для 1С, принимающая вес с железнодорожных, автомобильных, крановых весов

Инструменты и обработки Программист Пользователь Компонента, плагин (dll, vbs,..) v7.7 v8 Транспорт, автопарки, такси Россия Windows Платные (руб) Разработка внешних компонент

Программа "Компонента приёма веса для 1С, версия 3.0" позволяет принимать и заносить вес с весов непосредственно в программу "1С" - то есть, прием веса осуществляется целиком и полностью из программы "1С".

22000 руб.

09.04.2019    4065    3       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

SALE! 10%

Внешняя компонента печати PDF (Native Win 32/64)

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Платные (руб) Разработка внешних компонент

Внешняя компонента позволяет печатать PDF файлы непосредственно из 1С, не используя при этом сторонних программ. Прекрасно работает на сервере, тонком клиенте и веб-клиенте. Основана на проекте PDFium из состава проекта Chromium/Chrome

1000 руб.

17.09.2018    10523    91    36       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

SALE! 10%

Внешняя компонента для подключения 1С к телефонии Asterisk

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Россия Windows Платные (руб) Разработка внешних компонент Телефония, SIP

Внешняя компонента выполнена по технологии Native API для 1С 8.х, обеспечивает доступ к программным АТС Asterisk (FreePBX, Elastix) через AMI интерфейс. Через него можно управлять многими функциями Asterisk (определение номеров, перевод звонков, набор телефона и т. д.)

1000 руб.

04.05.2018    17880    33    19       

SALE! 10%

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла) с изменениями в ФЗ от 01/07/19

Инструменты и обработки Системный администратор Программист Бухгалтер Архив с данными v7.7 v8 1cv8.cf 1cv7.md Россия БУ УУ Windows Кассовые операции Платные (руб) Инструментарий разработчика Разработка внешних компонент WEB ККМ Фискальный регистратор Розничная торговля

FR_ATOL_SHTRIH.EXE встраивается в SYSTRAY (в правом нижнем углу, там где часы) и следит за появлением обычного текстового файла, в котором перечислено, какие операции необходимо осуществить с ККТ - напечатать чек (нал/безнал), снять Z-отчет, осуществить выемку денег, сделать возврат и т.д. Такой механизм позволяет использовать комплект для WEB сайтов, для нетиповых или сильно измененных 1с7 или 1с8. Для любых программ, которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые к использованию обработки для 1с8: УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1С7.7:ТиС документ Реализация ТМЦ,Печать из ПКО, Бух4.5, Бух1.3 . Код на 1с открыт - используйте обработки комплекта, как шаблоны для своих программ. Подключать ККМ к 1С не надо! Более 300 внедрений на ККМ Штрих и Атол. Некоторые из покупателей реализовали работу с ККМ даже из Excel и Axapta.

1000 руб.

31.07.2017    53762    356    370       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

SALE! 10%

Медиадисплей. Рекламный информационный монитор для покупателя.

Инструменты и обработки Программист Пользователь Приложение (exe) v8 КА1 УТ10 Розница УНФ ERP2 БП3.0 УТ11 КА2 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Реклама, PR и маркетинг УУ Windows Розничная торговля Платные (руб) Разработка внешних компонент POS терминал Рабочее место Мобильная разработка

Монитор покупателя может отображать текущую покупку на кассовом месте, показывать видеорекламу, баннеры, во время простоя разворачивать рекламу на весь экран. Можно использовать в качестве графического меню-борда в кафе и видеовывески. Управление выводом на телевизор через hdmi-приставку на базе Windows или Android. В качестве устройства отображения можно использовать Android-планшеты, фоторамки с Android, монитор любого Windows-компьютера, доступного по сети. Настраивается ЛЮБОЙ ДИЗАЙН экрана!

5000 руб.

30.05.2017    28125    498    27       

SALE! 10%

Сервер ККМ (54-ФЗ, быстрая печать чеков из терминального сеанса, печать с нескольких ПК)

Инструменты и обработки Системный администратор Программист Пользователь Приложение (exe) v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Windows Кассовые операции Розничная торговля Платные (руб) ККМ Разработка внешних компонент POS терминал Фискальный регистратор

"Сервер ККМ" позволяет приложениям работать с фискальными регистраторами из терминального сеанса Windows по локальной сети или интернет, организовать печать на одном ККМ с нескольких рабочих мест. Поддержка драйверов Атол, Штрих и VikiPrint. Поддержка 54-ФЗ. Подключается к 1С Торговля и склад 7.7, 1С:УТ 10/11, 1С:УНФ, 1С:Розница 1/2, 1С:БП 2/3, 1С КА 1/2., 1С:ERP, УПП

5000 руб.

02.09.2016    77758    2500    141       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

SALE! 10%

Компонента NativeAPI 1С для массового распознавания и печати штрих-кодов

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Россия Windows Платные (руб) Разработка внешних компонент

Программная компонента в формате NativeAPI 1C-предприятия (не ниже 8.2) предназначена для массового распознавания штрих-кодов из файлов на жестком диске, или загруженных в память компьютера из базы данных или любым другим способом, а также отображения штрих-кодов без использования дополнительных компонентов на стороне клиента.

8000 руб.

15.08.2016    30196    109    35       

SALE! 10%

Внешняя компонента для генерации QR-кодов в 1С для ЕГАИС

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 1cv8.cf 1cv7.md Розничная и сетевая торговля (FMCG) Платные (руб) Разработка внешних компонент

«Автоматизация бизнеса: QR-код» – внешняя компонента для «1С:Предприятие», которая позволяет генерировать QR-код в формате BMP. Актуальна для тех, кто обязан подключиться к ЕГАИС в части продаж. Благодаря этой компоненте, вы сможете печатать QR-код на фискальных регистраторах, которые не поддерживают генерацию QR-кодов.

4000 руб.

16.06.2016    21591    56    1       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

SALE! 10%

SIP софтфон для 1С:Предприятия

Инструменты и обработки no Приложение (exe) v8 Windows Платные (руб) Разработка внешних компонент Телефония, SIP

SIP софтфон для 1С:Предприятия — это программный телефон, реализованный по технологии ActiveX с возможностью интеграции с 1С версии 8.x. SIP софтфон является самостоятельным приложением, и его работа не зависит от работоспособности 1С:Предприятия. Таким образом, при временной неработоспособности 1С вы остаетесь на связи для своих клиентов. По входящему звонку вы можете осуществить поиск контрагента в базе, передать на панель вызовов софтфона необходимую информацию, создать новый документ, автоматически заполнив реквизит «Контрагент» или осуществить исходящий звонок непосредственно из 1С, не разворачивая окно софтфона. Единственное ограничение — это ваша фантазия. SIP софтфон работает по протоколу SIP 2.0 и совместим со всеми АТС, поддерживающими данный протокол.

2800 руб.

13.08.2015    30097    329    12       

SALE! 10%

Кроcсплатформенное динамическое выполнение кода .NET (C#) из 1С:Предприятие

Инструменты и обработки Программист Подсистема v8 1cv8.cf Платные (руб) Разработка внешних компонент

Библиотека позволяет динамически выполнять фрагменты кода, написанные на C# аналогично функции Выполнить в 1С:Предприятие, на компьютерах под управлением ОС Windows и Linux. Имеется возможность передавать параметры, возвращать результаты выполнения, загружать сборки .NET, а также отслеживать ошибки выполнения кода C#. Библиотека оформлена в виде подсистемы.

2500 руб.

02.06.2015    15740    30    11       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

SALE! 10%

V82Jpeg - Компонента обработки изображений

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Платные (руб) Разработка внешних компонент

Работа с изображениями: преобразование форматов, сжатие/расширение, простейшие операции редактирования, чтение атрибутов фотографий и их классификация по параметрам съемки - все это только из 1С без установки дополнительного софта.

10000 руб.

26.02.2015    14469    43    10       

SALE! 10%

Богатый редактор картинок, хранимых в базе, с возможностью РИСОВАНИЯ. Редактор внешних файлов картинок. Объект, расширяющий возможности работы с картинками из встроенного языка (Три в одном) + Обработка «Стандартизация картинок»

Инструменты и обработки no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Платные (руб) Инструментарий разработчика Универсальные обработки

Обработка предназначена для редактирования картинок в режиме «Предприятие», с возможностью РИСОВАТЬ на них. Поддерживается работа как в обычных формах (толстый клиент) так и на управляемых формах (тонкий клиент). Обработка позволяет редактировать как картинки, хранимые в базе, так и графические файлы с диска на файловой системе. Помимо базовых функций (изменение размеров, преобразование формата, обрезание картинки, повороты и т.п.) – редактор имеет богатый набор инструментов для рисования. Доступна функция вставки изображения из буфера обмена. Это все позволяет существенно упростить работу с картинками. Также обработка может быть использована из встроенного языка как объект для редактирования картинок с набором экспортных процедур и функций для реализации иных бизнес задач (как пример в состав включена обработка "Стандартизация картинок"). Этот объект является альтернативой стандартного объекта «Картинка» с расширенными возможностями. Объект может быть использован: на стороне клиента, на стороне сервера, из внешнего соединения. Это позволяет существенно упростить и автоматизировать работу с картинками. Данная обработка будет особенно полезна тем, кто вносит картинки в базу (изображения номенклатуры, фотографии физических лиц и т.п.). Функционал реализуется с использованием JavaScript и бесплатного ПО ImageMagick (без использования внешних компонент).

5000 руб.

16.01.2015    41327    185    37       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

SALE! 10%

Работа с PowerShell из 1С

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Платные (руб) Разработка внешних компонент

Библиотека позволяет выполнять фрагменты кода PowerShell из 1С, аналогично встроенной процедуре Выполнить. Имеется возможность передавать параметры, возвращать результаты выполнения, генерировать внешние события, а также отслеживать ошибки выполнения кода PowerShell. Библиотека оформлена в виде подсистемы.

2000 руб.

28.04.2014    36548    38       

SALE! 10%

Мастер создания внешних компонент 1С (технология COM) для DELPHI 6/7/8/2005/2006/2007/2008/2010/XE/XE2/XE3

Инструменты и обработки Программист Приложение (exe) v8 Windows Платные (руб) Разработка внешних компонент

Средство для сверхбыстрой разработки внешних компонент 1С:Предприятия 7.7 и 8 по технологии COM на всех версиях DELPHI, начиная с 6.

1000 руб.

28.03.2013    40971    13