Создание подключаемой обработки табличной части с диалогом запроса параметров заполнения (управляемые формы)

Публикация № 825702

Администрирование - Администрирование данных 1С - Обработка документов

обработка создание табличная часть отладка управляемая форма

39
Пошаговый пример покажет, как сделать обработку табличной части для документа, предварительно открывающую диалоговое окно, где пользователь может указать требуемые характеристики (параметры), по которым произойдет обработка.

Зачастую перед заполнением от пользователя нужно получить какие либо указания для дальнейшего выполнения. Можно спросить Да/Нет или какое-то значение, но когда необходимо запросить более развернутую информацию, перечислять вопросы неудобно ни пользователю, ни для функционирования.

После появления такой задачи и возникла необходимость этого решения. Думаю, оно пригодится и другим.

Задача: В конфигурации Бухгалтерия предприятия 3.0 создать обработку заполнения табличной части, при запуске которой откроется диалог указания необходимых параметров для изменения имеющихся данных. Работа с документом Реализация (акты, накладные), перед заполнением нужно спросить Номенклатуру и как нужно изменить ей цену.

Приступим к реализации:

Первым делом напишем в модуле созданной обработки процедуры регистрации:

 Функция СведенияОВнешнейОбработке() Экспорт
    Назначения = Новый Массив ;
    Назначения.Добавить("Документ.РеализацияТоваровУслуг") ;
     
    ПараметрыРегистрации = Новый Структура ;
    ПараметрыРегистрации.Вставить("Вид","ЗаполнениеОбъекта");
    ПараметрыРегистрации.Вставить("Назначение",Назначения);
    ПараметрыРегистрации.Вставить("Наименование","Пример обработки табличной части с диалогом запроса параметров");
    ПараметрыРегистрации.Вставить("Версия","1.0");
    ПараметрыРегистрации.Вставить("Информация","Дополнительная обработка табличной части");
    ПараметрыРегистрации.Вставить("БезопасныйРежим",Истина);
     
    Команды = ПолучитьТаблицуКоманд() ;
    ДобавитьКоманду(Команды, "Тестовая обработка",
            "ЗаменитьФинансирование","ВызовКлиентскогоМетода",Ложь,) ;
     
    ПараметрыРегистрации.Вставить("Команды",Команды) ;
     
    Возврат ПараметрыРегистрации;
     
КонецФункции
 
Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений ;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка")) ;
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")) ;
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")) ;
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево")) ;
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка")) ;
    Возврат Команды;
КонецФункции   
 
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор,
                Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    НоваяКоманда = ТаблицаКоманд.Добавить() ;
    НоваяКоманда.Представление = Представление ;
    НоваяКоманда.Идентификатор = Идентификатор ;
    НоваяКоманда.Использование = Использование ;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение ;
    НоваяКоманда.Модификатор = Модификатор ;
КонецПроцедуры

В реквизиты обработки добавим реквизит Документ, который пригодится при отладке и будет применяться при зарегистрированном использовании. Этот вариант дает некоторую универсальность. Можно тестировать, отлаживать и, если все в порядке, сразу подключить пользователю.

Теперь нам нужна основная форма, которая будет видна только при запуске через Файл - Открыть, но её процедуры нужны в любом случае. А так-же нужна вторая форма, назовем её "ЗапросПараметров", она станет служить для указания параметров пользователем.

В модуль основной формы пишем:

Перем ОбъектЗаполнения Экспорт;

&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    Если НЕ ЗначениеЗаполнено(Объект.Документ) Тогда
         Объект.Документ = ВладелецФормы.Объект.Ссылка;
    КонецЕсли;
    ОбъектЗаполнения=Объект.Документ;
    ЗакрытиеФормы = Новый ОписаниеОповещения
    ("ЗаполнениеПоВыбраннымПараметрам", ЭтаФорма); // Название процедуры, которая будет выполняться после закрытия формы "ЗапросПараметров"
    ЗапросПараметров = ОткрытьФорму("ВнешняяОбработка.ПримерОбработкиТабличнойЧастиСДиалогомПараметров.Форма.ЗапросПараметров", ,ОбъектЗаполнения,,,,ЗакрытиеФормы);
КонецПроцедуры

Эта часть перебрасывает нас на форму параметров, так что переходим на неё. Добавляем требуемые реквизиты, и пару команд (Выполнить и Отмена):

В процедуре кнопки Выполнить напишите:

 
    Парам = Новый Структура("ОбъектДляЗаполнения,Номенклатура,ИзменениеЦены");
    Парам.ОбъектДляЗаполнения = ВладелецФормы;
    Парам.Номенклатура = ЭтаФорма.Номенклатура;
    Парам.ИзменениеЦены = ЭтаФорма.ИзменениеЦены;
    ЭтаФорма.Закрыть(Парам);

Для кнопки Отмена:

    ЭтаФорма.Закрыть(Неопределено);

Теперь эта форма поместит указанные реквизиты в структуру и передаст её в основную форму.

Заключительная часть обработки табличной части происходит в модуле основной формы, следовательно добавляем в него:

&НаКлиенте
Процедура ЗаполнениеПоВыбраннымПараметрам(Результат, Параметры) Экспорт
    Если НЕ ЗначениеЗаполнено(Результат) Тогда
        Возврат; // Пользователь не стал указывать параметры, останавливаем работу
    КонецЕсли;
    ОбъектЗаполнения = ЗаполнениеНаСервере(ОбъектЗаполнения, Результат); // Результат содержит структуру, полученную из формы "ЗапросПараметров"
    Если НЕ ВладелецФормы=Неопределено Тогда
        ВладелецФормы.Прочитать(); // Если обработка вызывалась из документа, то нужно перечитать изменения, чтобы пользователь видел результат обработки
    КонецЕсли;
КонецПроцедуры
 
&НаСервере
функция ЗаполнениеНаСервере(ОбъектЗаполнения, Параметры = Неопределено)
    Если ЗначениеЗаполнено(Объект.Документ) Тогда // Проверяем режим запуска: Через Открыть или из документа
        Док = Объект.Документ.ПолучитьОбъект();
    Иначе Док = ОбъектЗаполнения;
    КонецЕсли;
    Для каждого Стр Из Док.Товары Цикл // Цикл обработки табличной части "Товары"
        Если Стр.Номенклатура = Параметры.Номенклатура Тогда
            Стр.Цена = Стр.Цена+Стр.Цена/100*Параметры.ИзменениеЦены;
            Стр.Сумма = Стр.Сумма+Стр.Сумма/100*Параметры.ИзменениеЦены;
        КонецЕсли;
    КонецЦикла;     
   Док.Записать(); // Сохраняем результат
КонецФункции

Остался маленьких штрих. Основная форма осталась пустой, но так не должно быть. Поместите на неё созданный ранее реквизит Документ и добавьте кнопку ВыполнитьОбработку, при нажатии на которую выполнится одна команда:

    ВыполнитьКоманду("", Объект.Документ);

Задача выполнена. Разумеется, сим я показал принцип, а не единое руководство решения любой проблемы. Надеюсь, предложенный вариант поможет сэкономить время на решение реальных вопросов.

Для работы использовалась платформа 1С:Предприятие 8.3 (8.3.11.3034).

Метод использовался при создании обработки Замена финансирования определенных видов расчета в документе Начисление зарплаты и взносов (ЗИКГУ 3.1)

39

Скачать файлы

Наименование Файл Версия Размер
Пример - Создание подключаемой обработки табличной части с диалогом запроса параметров заполнения (Управляемые формы):
.epf 10,39Kb
03.05.18
91
.epf 10,39Kb 91 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Lapitskiy 904 12.05.18 03:50 Сейчас в теме
Суть прекрасно описано.
Но есть одно НО.
Документ записывается после обработки, а это методически не верное решение.
А причина - в изменении данных "Объект", а правильно изменять данные "Форма".
Тогда всё измененное, сразу отобразится на форме, без костылей типа "Записать", "Прочитать".
rpgshnik; PLAstic; +2 Ответить
2. Mirage78 61 12.05.18 10:18 Сейчас в теме
(1) К сожалению, пришлось задействовать этот грубый вариант "Объект/Записать/Прочитать", и причина в ограничениях платформы. Смысл обработки именно в обработке, а не в заполнении табличной части с нуля. Изменять существующую табличную часть формы проблематично ...
3. ltfriend 419 28.05.18 22:06 Сейчас в теме
Код модуля с регистрацией обработки можно существенно сократить
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();
	ПараметрыРегистрации.Наименование = НСтр("ru='Пример обработки табличной части с диалогом запроса параметров'");
	ПараметрыРегистрации.Информация = НСтр("ru='Дополнительная обработка табличной части'");
	ПараметрыРегистрации.Версия = "1.0";
	ПараметрыРегистрации.Назначение.Добавить("Документ.РеализацияТоваровУслуг");
	
	Команда = ПараметрыРегистрации.Команды.Добавить();
	Команда.Идентификатор = "ЗаменитьФинансирование";
	Команда.Представление = "Тестовая обработка";
	Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	
	Возврат ПараметрыРегистрации;
	
КонецФункции
Показать

Да и формой можно тоже обойтись одной. Вот полный код формы (без всяких "записей-перезаписей"):
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	ОбъектНазначения = Параметры.ОбъектыНазначения[0];
	
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьОбработку(Команда)
	
	ПараметрыФормы = Новый Структура("Ключ", ОбъектНазначения);
	ФормаДокумента = ПолучитьФорму("Документ.РеализацияТоваровУслуг.ФормаОбъекта", ПараметрыФормы);
	
	ОбъектДокумента = ФормаДокумента.Объект;
	
	ЗаполнитьДокументНаСервере(ОбъектДокумента);
	
	КопироватьДанныеФормы(ОбъектДокумента, ФормаДокумента.Объект);
	
	ФормаДокумента.Модифицированность = Истина;
	
	Закрыть();
	
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьДокументНаСервере(ОбъектДокумента)
	
	Для каждого СтрокаТовар Из ОбъектДокумента.Товары Цикл
		Если СтрокаТовар.Номенклатура = Номенклатура Тогда
			СтрокаТовар.Цена = СтрокаТовар.Цена + СтрокаТовар.Цена/100 * ИзменениеЦены;
			СтрокаТовар.Сумма = СтрокаТовар.Сумма + СтрокаТовар.Сумма/100 * ИзменениеЦены;
		КонецЕсли;
	КонецЦикла;
	
КонецПроцедуры
Показать
rpgshnik; iosys; LiebeMein; adhocprog; KpoTuk; Nuuq; Sergant; user958854; +8 Ответить
4. Mirage78 61 29.05.18 10:11 Сейчас в теме
(3) Параметры регистрации прописывались в старых обработках, и я не заморачиваясь скопировал этот фрагмент. В остальном реализация интересная, но непонятно что значит "формой можно обойтись одной". Смысл в том, что параметр далеко не один. На форму можно набросать разные реквизиты (списки выбора/таблицы значений и т.д.), а основная форма используется при открытии через Файл и для отладки.

Или речь о том, что можно не возвращаться с параметрами на основную ... Думаю да, я начинал с основной, поэтому на автомате и вернулся к ней получив параметры.
5. ltfriend 419 29.05.18 11:17 Сейчас в теме
(4) Одна форма - это то, что можно нарисовать одну форму с параметрами, в параметрах регистрации указываем вид ОткрытиеФормы, в форме при создании на сервере запоминаем объект назначения (ссылка на документ), при нажатии на кнопку выполняем заполнение (процедура ВыполнитьОбработку в коде выше - это обработчик команды кнопки).
adhocprog; Mirage78; +2 Ответить
6. Mirage78 61 29.05.18 12:37 Сейчас в теме
(5) Упс, забыл про вид, спасибо.
7. OksDallas 22 28.06.18 08:56 Сейчас в теме
(5)
Управление торговлей, редакция 11 (11.4.5.24)

К сожалению, не поняла, как можно указать в параметрах регистрации вид ОткрытиеФормы. Пробовала вот так:
    ...
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.СообщениеSMS");

    ПараметрыРегистрации.Вставить("Вид", "ОткрытиеФормы");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Заполнить по подразделению");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Информация", "Дополнительная обработка табличной части к документу Сообщение SMS");
...
Показать


Дает ошибку с ссылкой на отсутствие соответствующего перечисления ВидыДополнительныхОтчетовИОбработок. Действительно, в перечислении есть только следующее:
- ДополнительнаяОбработка
- ДополнительныйОтчет
- ЗаполнениеОбъекта
- Отчет
- ПечатнаяФорма
- СозданиеСвязанныхОбъектов
- ШаблонСообщения
- РасчетСкидкиНаценки
- ПроверкаУсловияПредоставленияСкидкиНаценки

В УФ еще плаваю - куда влезла, что делаю???
10. Stivens 11 07.11.18 02:06 Сейчас в теме
(3) Убился. В Клиент-серверном варианте открывает второй экземпляр формы документа. Причем в первом старые данные, во втором - новые.
В файловом все нормально, изменяет именно вызвавшую форму.
Прикрепленные файлы:
ШаблонВОТЧсОтладкойИДиалогом.epf
13. androidT1C 73 04.07.19 10:02 Сейчас в теме
(10) Ветка старая, но:
если вместо:
ПараметрыФормы = Новый Структура("Ключ", Поступление);
ФормаДокумента = ПолучитьФорму("Документ.ПоступлениеТоваровУслуг.ФормаОбъекта", ПараметрыФормы);

написать:
ФормаДокумента = ВладелецФормы;

то будет работа именно с формой текущего документа
Batman; generick; adhocprog; gucci76; +4 Ответить
8. OksDallas 22 28.06.18 09:39 Сейчас в теме
Все, нашла. "ОткрытиеФормы" надо в ТаблицуКоманд привязывать.
ДобавитьКоманду(ТаблицаКоманд, "Заполнить документ", "Заполнить документ", "ОткрытиеФормы", Истина);
9. Mirage78 61 28.06.18 12:45 Сейчас в теме
(8) именно, я не стал поправлять Павла, просто понял о чём речь ...
11. alexd73 05.04.19 23:00 Сейчас в теме
Спасибо за мануал. подскажите, если я хочу выгрузить накладную в xml по кнопке - тоже надо делать через "ЗаполнениеОбъекта"? Или как?
И мне формы не нужны. Надо просто создать файл и вывести сообщение об этом.
подскажите эти моменты.


Заранее спасибо!
12. independ 705 06.04.19 00:04 Сейчас в теме
(11) да, или через внешнюю печатную форму или создание связанных объектов и проч. Учитывая, что файл нужен на клиенте, то логику обработки проще поместить в модуль формы, вызов сделать в процедуре ПриОткрытии(), после всех манипуляций там же выполнить закрытие формы, т.е. форма обработки на экране не появится.
14. German_Tagil 7 18.07.19 15:25 Сейчас в теме
Придется обращаться к первоисточнику
Оставьте свое сообщение

См. также

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

html + css + js в поле HTML документа 1С на примере решения задачи ханойских башен 15

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования

Рассматривается пример использования html + css + js в полеHTMLдокумента 1с. Вызов функций javascript со стороны 1С с передачей параметров. Решение головоломки "Ханойская башня" с визуализацией в среде 1С.

1 стартмани

11.11.2019    1427    2    mangushov    0       

История версий объектов для УФ 49

Отчеты и формы Программист Пользователь Архив с данными v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Журнал регистрации Обработка документов Обработка справочников

Универсальная независимая система хранения и анализа истории изменений справочников и документов. Предназначена для любых конфигураций 1С V83 ((8.3.9.1818) и выше) в режиме управляемого приложения.

1 стартмани

17.10.2019    4565    21    dmitrydemenew    19       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Описание формата внутреннего представления данных 1С в контексте обмена данными 153

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    6848    6    Dementor    27       

Обмен с системой Ветис Меркурий для любых конфигураций. Гашение ВСД, списание продукции, пакетная печать ВСД (простые и управляемые формы) 11

Инструменты и обработки Системный администратор Программист Бухгалтер Пользователь Внешняя обработка (ert,epf) v8::ОУ v8::УФ УТ10 УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Пищевая промышленность Россия БУ УУ Windows Розничная торговля Абонемент ($m) Обработка документов Внешние источники данных Рабочее место

Обработка предназначена для небольшого магазина или для небольшой торговой сети. Позволяет оперативно пакетно погасить ВСД, списать проданную продукцию в системе Меркурий, реализована пакетная печать ВСД. Авторизация проходит через Логин и Пароль, предназначенный для входа через веб интерфейс Меркурий. Проверка была проведена на релизе Обычные формы: "Управление торговлей", редакция 10.3 (10.3.53.2). Управляемые формы: Управление торговлей, редакция 11 (11.4.7.128)

5 стартмани

02.09.2019    2961    25    Mister_Gluck    26       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Обновление данных в ячейках таблицы формы на управляемых формах 9

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Разработка Работа с интерфейсом

На очередном проекте решал задачу по расчету значений колонок в табличных полях формы. Задача казалась достаточно простой. Однако возникла необходимость работать не только с реквизитами формы типа «ТаблицаЗначений», но и с типом «ДеревоЗначений». Релиз платформы 8.3.13.1644

1 стартмани

15.08.2019    1730    BraunAlex    2       

Удобный выбор из таблицы/дерева в УФ 61

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

Выбор из таблицы значений или дерева значений в выпадающем списке рядом с полем ввода - УФ, быстро и просто!

1 стартмани

12.08.2019    5130    4    Yashazz    18       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Отбор на управляемой форме из списка значений 42

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

Пример простого удобного отбора любых данных ссылочного типа на управляемой форме. Работа обработки проверена на релизе: 1С:Предприятие 8.3.13.1513.

1 стартмани

09.08.2019    6361    5    nagaitseff    6       

Изменяющееся контекстное меню в 1С 8.3 45

Статья Программист Архив с данными v8 v8::УФ Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    6211    1    signum2009    15       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Универсальный ввод на основании 12

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Обработка документов

Дополнительная обработка создания связанных объектов, позволяющая ввести любой документ на основании произвольного документа или даже списка документов. Подойдет для любой конфигурации под управляемые формы.

1 стартмани

11.06.2019    2948    21    the1    6       

Картинки во внешней печатной форме (Шапка и табличная часть) 10

Статья Программист Внешняя обработка (ert,epf) v8::ОУ v8::УФ УТ11 Россия Абонемент ($m) Печатные формы документов Практика программирования Разработка

Способы вывести на печать картинку в шапке и в табличной части внешней печатной формы. Управление торговлей, редакция 11 (11.4.7.150).

1 стартмани

27.05.2019    2992    2    Povinger    1       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Спутник программиста - каркасная конфигурация начинающим программистам 1С 66

Инструменты и обработки Программист Стажер Архив с данными v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Практика программирования Разработка

Спутник программиста - каркасная конфигурация с примерами для разработки начинающим программистам 1С.

1 стартмани

23.05.2019    10460    96    bulas    27       

Поле "Отбор" в управляемой форме используя СКД 9

Отчеты и формы Программист Внешняя обработка (ert,epf) v8::УФ v8::СКД 1cv8.cf Абонемент ($m) Работа с интерфейсом Практика программирования Разработка

Пример, который осуществляет отбор ссылок при помощи СКД, макет компоновки создается программно.

1 стартмани

17.05.2019    3226    3    artms    0       

Перенос данных БП 2.0 => УТ 11 / КА 2 / ERP 2 (перенос остатков, документов и справочников из "1С:Бухгалтерия предприятия 8", ред. 2.0 в "1С:Управление торговлей 8", ред.11 / КА 2 / ERP 2). Обновлено до УТ 11.4.10.х, КА 2.4.10.х, ERP 2.4.10.х! Промо

Перенос позволяет загрузить в УТ 11 / КА 2 / ERP 2 документы за выбранный период, справочную информацию и остатки по счетам бух. учета. Переносятся остатки денежных средств, взаиморасчетов, остатки товаров и материалов на складах. Переносятся девятнадцать основных видов документов за выбранный период и вся нормативно-справочная информация. Есть фильтр по организации. Если нужно переносить что-то дополнительно, то обычно бесплатно дорабатываю правила (перед покупкой согласуйте необходимые доработки).

29700 руб.

Табличная часть из дополнительных реквизитов с обработкой событий в расширении 7

Статья Программист Расширение (cfe) v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

Эмуляция табличной части с помощью дополнительных реквизитов и расширения. Подход применим к любой конфигурации на управляемых формах с БСП и режимом совместимости, допускающим использование расширений. Весь код в статье.

1 стартмани

13.05.2019    3842    1    mvxyz    7       

Группировка по виду документа в "Задачи мне" (расширение для 1С:Документооборот) 10

Инструменты и обработки Программист Пользователь Расширение (cfe) v8::УФ v8::Запросы v8::Бизнес-процессы ДО УУ Документооборот и делопроизводство Абонемент ($m) Обработка документов Работа с интерфейсом

Расширение для 1С:Документооборот (2.1), позволяющее сгруппировать все задачи из списка "Задачи мне" по виду документа (служебные записки, приказы и т.д.).

3 стартмани

16.04.2019    3594    16    zannv    16       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Вывод вариантов СКД в таблицы на управляемой форме 26

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    5098    1    artkor    1       

Методика оптимизации программного кода 1С: проведение документов 85

Инструменты и обработки Программист Архив с данными v8 v8::УФ Абонемент ($m) Обработка документов Производительность и оптимизация (HighLoad) Инструментарий разработчика

Описание простого метода анализа производительности программного кода 1С, способов его оптимизации и оценки результатов в виде числовых показателей прироста производительности. Не требует сторонних программных продуктов, используются только типовые возможности платформ 1С. Методика проверена на линейке платформ начиная с 1С:Предприятие 8.2 (обычные формы, управляемые формы). Позволяет ускорить проведение проблемных документов в 3 и более раз, провести проверку корректности формирования проводок оптимизированным кодом и подтвердить результаты оптимизации реальными замерами производительности в режиме предприятия. К публикации приложены демонстрационные базы для режимов обычного и управляемого приложения на платформе 1С:Предприятие 8.3 (8.3.9.2033).

1 стартмани

19.03.2019    15605    14    dmitrydemenew    83       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Перенумерация объектов (Справочники + Документы) 12

Инструменты и обработки Программист Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Обработка документов Обработка справочников

Обработка позволяет перенумеровать выбранный справочник или документ. Помогает решить проблему: Номер не уникальный. Для управляемого интерфейса.

1 стартмани

18.03.2019    3166    38    Смешной 1С    2       

Создание и редактирование таблиц в поле HTML документа 7

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Практика программирования Разработка

Создание и редактирование таблиц в поле HTML документа. Тестировалось на 1С:Предприятие 8.3.12.1616

1 стартмани

16.03.2019    3146    6    lastpioneer    0       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Программное создание реквизита управляемой формы с помощью механизма расширений 92

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Разработка

В ЗУП 3 возникла задача добавить реквизит в справочник не внося изменений в конфигурацию. БСП с механизмом дополнительных реквизитов использовать было нежелательно, поэтому был использован механизм расширений. Для вывода данного реквизита на форму добавлять саму форму в расширение не хотелось по ряду причин, описанных ниже. Создание реквизита и элемента формы, соответствующего данному реквизиту было решено сделать программно в самом расширении, следуя принципу минимального воздействия на конфигурацию.

1 стартмани

12.03.2019    16888    8    ni_cola    24       

1С Документооборот: Создание связанных документов по настройкам связей 9

Инструменты и обработки Программист Пользователь Архив с данными v8 v8::УФ ДО Документооборот и делопроизводство Абонемент ($m) Обработка документов

Типовой механизм "Создания на основании" в 1С Документооборот обеспечивает лишь базовую потребность ввода документов на основании. Например типовой механизм не позволяет создать документ с видом документа, у которого нет ни одного введенного шаблона документа (т.е. прийдется создать пустой и выбрать вид документа). С другой же стороны, если общее количество шаблонов по видам внутренних документов превышает 50 штук - выбор нужного шаблона из типовой формы создания на основании "внутреннего документа" может занимать драгоценное время и быть не оптимальным.

1 стартмани

28.02.2019    3840    2    Bin42    1       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Заполнение табличной части "Возврат материалов из эксплуатации" с диалогом запроса параметров заполнения (управляемые формы) 0

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::БУ v8::УФ БП3.0 Россия БУ Учет ТМЦ Абонемент ($m) Обработка документов

Заполнение табличной части "Спецодежда", документа "Возврат материалов из эксплуатации" остатками по физ. лицу, внешней обработкой заполнения табличной части.

1 стартмани

25.02.2019    2114    7    alex649    1       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Использование макетов вместо дополнительных реквизитов или регистров сведений 37

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Разработка

Использование макетов вместо дополнительных реквизитов или регистров сведений на конфигурациях с БСП.

1 стартмани

27.01.2019    6362    2    Comandante    22